I'm trying to install an NVIDIA Driver, but I must turn off the Xserver first. I've tried a lot of methods I found online, but none seem to work.

I'm using Antergos with GNOME.

  • Ctrl + Alt + Backspace kills the server, but then the graphical login screen starts again.
  • sudo service stop lightdm says there isn't a command service
  • Tried switching with Ctrl + Alt + f1 and then killing the server (with kill or pkill), but that had two outcomes: It did nothing or I got a blackscreen
  • systemd <\something> also says there's no such command (systemd)
  • Installing the drivers with pacman crashes my Antergos install and I must do a new install

EDIT: Turned out that my Graphics Card supports optimus and I managed to install the drivers following this wiki post: Bumblebee for NVIDIA

1 Answer 1


From the commands you are using, I take it that you use Systemd and LightDM.

The correct command to stop the display server is

sudo systemctl stop lightdm

I think it's safe to run from a graphical terminal, not only from TTY. If you want to disable auto starting of LightDM altogether, replace stop with disable.

Note that stopping the X server, even from a TTY may switch back to the TTY the X server ran in, so if you get a blackscreen, switch to another TTY.

If you want to restart LightDM, use

sudo systemctl start lightdm

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .