2

I try to disable complety ipv6 on a Linux Debian 7 (wheezy) However , things escape me. In my case, i test with grafana process (I have same issue with munin, rpcbind etc)

Method 1 : with sysctl

net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.default.autoconf = 0
net.ipv6.conf.all.autoconf = 0
net.ipv6.conf.lo.disable_ipv6 = 1
net.ipv6.conf.eth0.disable_ipv6 = 1

Then, i reload config : sysctl -p

No registration ipv6 in /etc/hosts

After reboot process grafana, i always see, with netstat, that grafana listen ipv6 socket.

tcp6       0      0 :::3000                 :::*                    LISTEN      116        23952       4022/grafana-server

Reboot server : reboot the server does not improve things

Method 2 : disable ipv6 at kernel startup

Add GRUB_CMDLINE_LINUX="ipv6.disable=1" in /etc/default/grub Gen new conf : update-grub2

Reboot server : reboot the server does not improve things, i can see a listen ipv6 with netstat :

tcp6       0      0 :::3000                 :::*                    LISTEN      116        23952       4022/grafana-server

I have test

How it's possible to bind ipv6 socket if the stack is disable ? Display issues ? Anyone can explain me this behaviour ?

Best Regards,

migrated from stackoverflow.com Dec 10 '15 at 18:37

This question came from our site for professional and enthusiast programmers.

  • Oh, my bad. Sorry – nelmo Dec 8 '15 at 17:24
  • Yeah, no worries. You may get an answer here anyway ;-). (You won't get any friends by post Q to multiple sites. Also review ipv6 Qs at another Stackexchange site : http://serverFault.com. Good Q, but just not appropriate here (IHMO). Good luck. – shellter Dec 8 '15 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy