3

Has anyone gotten this error when trying to join CentOS 7 to Active Directory? I tried various ways(via cli, gui, tui) and always get same error.

Failed to join domain: failed to set machine kerberos encryption types: Insufficient access
  • do you use an AD account with admin right ? – Archemar Dec 8 '15 at 14:39
  • Yes, I tried to join RHEL 6.4 with same method to AD and it succeeded. – Losmino Dec 8 '15 at 14:42
  • 1
    post here the command what you did in the cli, please – Rui F Ribeiro Dec 8 '15 at 15:26
  • access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/… Do by this guide, and every tuturial is very similar to this. Also tried with realm join command with adjusting all required parameters. – Losmino Dec 8 '15 at 15:43
  • Any one with some help? – Losmino Dec 25 '15 at 12:49
0

I was able to successfully run:

net ads testjoin 

Even after receiving the same message on CentOS 7. I can login via my company AD successfully.

  • I get output when I run net ads testjoin: Join is OK – Losmino Feb 1 '16 at 16:29
0

The solution were just in front of me. Although error appears the machine is joined to AD, error is misleading . Useful command for checking if machine is in AD

net ads -P status

To provide machine stay in AD you need to create a kerberos ticket with

kinit

command.

Regards

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.