3

I have installed urxvt and mc.
There is a combination Alt + S in urxvt and the same combination in mc.
When i use mc through urxvt and press Alt + S, command of the urxvt works instead of command of the mc.
How can i disable shortcut Alt + S in urxvt in order to use this combination in mc?

3

You can disable the searchable-scrollback feature by putting this in your .Xresources:

URxvt.perl-ext-common: "default, -searchable-scrollback"

Source: urxvt manpage (under perl-ext in the Resources section)

1

If you want to keep the possibility of using searchable-scrollback, with a different keybinding (e.g. Alt+Shift+s) then you can add the following to your .Xresources:

URxvt.searchable-scrollback: Meta-Shift-S

According to the manpage this method is deprecated, but it works and what should have been the correct alternative:

URxvt.keysym.Meta-S:  builtin-string:
URxvt.keysym.Meta-Shift-S:  searchable-scrollback:start

doesn't seem to work for me (M-S-s is enabled, but M-s is not disabled for searchable-scrollback).

0

Apparently you have to compile it yourself, using the --disable-perl option.

See this mailing-list discussion where its developer gives his viewpoint on the matter: Re: disable all keybindings (2013).

  • Maybe it helps, but it is long task, so i haven't tried. – Reputet Jan 22 '16 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.