3

Recently I noticed that I could hear my hard drive spinning down very frequently, like once every 10-20 seconds. At that time spin down was set to 30 minutes using the following udev rule:

hdparm -B 127 -S 241 /dev/$kernel

This was confirmed by hdparm:

$ sudo hdparm -I /dev/sda | grep level
        Advanced power management level: 127 

So I disabled power management with

$ sudo hdparm -B 255 /dev/sda
$ sudo hdparm -I /dev/sda | grep level
        Advanced power management level: disabled

But the drive is still spinning down frequently:

$ sudo smartctl -a /dev/sda | grep Load_Cycle_Count
225 Load_Cycle_Count        0x0032   100   100   000    Old_age   Always       -       8263
$ date
Mon  7 Dec 16:08:06 GMT 2015
$ sudo smartctl -a /dev/sda | grep Load_Cycle_Count
225 Load_Cycle_Count        0x0032   100   100   000    Old_age   Always       -       8265
$ date
Mon  7 Dec 16:08:16 GMT 2015

(I know this spin down count is low, I've just moved the installation to a new drive. I assume that the issue was the same with the old drive, but I just didn't notice. The cont on the older drive is 284,572 which I installed six months ago.)

What could be causing my hard drive to spin down and what can I do next to investigate?

2

R00KIE on the Arch Linux Forums correctly suggested that I try hdparm -B 254 /dev/sda. This has stopped drive spinning down so often, and the drive now obeys my hdparm -S 241 /dev/sda setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.