0

I want to install collectd version 5.2 or above. when I do yum install collectd, it installs 4.10 version but on this version, my software does not work. please help

  • Which distribution do you use? – LilloX Dec 7 '15 at 14:54
  • It is CentOS... – anurag Dec 7 '15 at 14:57
  • Which version? 6.x? – LilloX Dec 7 '15 at 15:07
  • lsb_release -a LSB Version: :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch Distributor ID: CentOS Description: CentOS release 6.5 (Final) Release: 6.5 Codename: Final – anurag Dec 7 '15 at 15:10
  • 1
    Ok,as mentioned earlier collectd version 5.x is not present in the official and unofficial repositories for centos 6. If you can switch to Centos 7 there is, in the repository EPEL, the requested version, otherwise you can try to rebuild the 5.X following these instructions (i have not tried this solution): gist.github.com/tnolet/7361441 – LilloX Dec 7 '15 at 15:15
0

If you know the rpm location you can directly install it via yum without downloading it.

For eg:

 yum install http://something.com/package1.rpm 
  • It is not that simple. the answer given does not take into account the possible dependencies that still would not be satisfied.If the official repositories does not have the required version probably are missing dependencies too. – LilloX Dec 7 '15 at 14:14
  • @LilloX. Agreed. I think this will take care if a package cannot be installed just because the version in the repo is missing and it meets all the other dependencies. – Vaisakh Dec 7 '15 at 14:20
  • tried below yum install ftp.pbone.net/mirror/archive.fedoraproject.org/fedora/linux/… But got the below message --> Processing Dependency: systemd-units for package: collectd-5.2.0-1.fc18.x86_64 --> Processing Dependency: systemd-units for package: collectd-5.2.0-1.fc18.x86_64 --> Processing Dependency: libpython2.7.so.1.0()(64bit) for package: collectd-5.2.0-1.fc18.x86_64 Packages skipped because of dependency problems – anurag Dec 7 '15 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.