0

I use Linaro version of Linux (Linaro 12.11) on my embedded target with ARM9 Core. For a certain profiling, I need to use the perf tool. perf require linux-tools-3.15.0 to be installed on my device. But all attempts to do this is going in-vain. Lastly I tried

sudo wget --no-check-certificate "https://launchpad.net/~canonical-kernel-team/+archive/ppa/+build/5980376/+files/linux-tools-3.15.0-0-generic_3.15.0-0.1_armhf.deb"

But it gave the result

--1970-01-12 04:57:03--  https://launchpad.net/~canonical-kernel-team/+archive/ppa/+build/5980376/+files/linux-tools-3.15.0-0-generic_3.15.0-0.1_armhf.deb
Resolving launchpad.net (launchpad.net)... 91.189.89.222, 91.189.89.223
Connecting to launchpad.net (launchpad.net)|91.189.89.222|:443... connected.
WARNING: cannot verify launchpad.net's certificate, issued by `/C=US/O=DigiCert Inc/OU=www.digicert.com/CN=DigiCert SHA2 Extended Validation Server CA':
Issued certificate not yet valid.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://launchpad.net/~canonical-kernel-team/+archive/ubuntu/ppa/+build/5980376/+files/linux-tools-3.15.0-0-generic_3.15.0-0.1_armhf.deb [following]
--1970-01-12 04:57:05--  https://launchpad.net/~canonical-kernel-team/+archive/ubuntu/ppa/+build/5980376/+files/linux-tools-3.15.0-0-generic_3.15.0-0.1_armhf.deb
Reusing existing connection to launchpad.net:443.
HTTP request sent, awaiting response... 404 Not Found
1970-01-12 04:57:05 ERROR 404: Not Found.
0

It is because the file does not exists. The perf is part of linux-tools package as far as I know.

You should be able to install it by traditional way apt-get install linux-tools from standard sources. If not, post what happened when you tried and what kernel version are you using.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.