1

I'm trying to change my resolution using xrandr command line but when I type in a terminal xrandr --output LVDS1 --mode 1600x900_60.00 (which I added using --addmode), it doesn't change my resolution but doesn't return an error neither. My screen just blink for a second then nothing.

I'm able to change the resolution I want through system settings > display, but i'd like it to work with the command line to use it as a program argument.

I'm using the nvidia proprietary driver, I don't know if it has something to do with that.

edit : the xrandr -s command says that the size is not found in available modes, whatever is the resolution I put, even those listed on xrandr -q.

Thanks in advance !

2

I cannot comment so posting as an answer. (On a second thought, it is too much for just a comment.)

Looks like I have the same problem. I don't have a solution, but I think I found what causes the problem and have a (kind of) workaround.

I am using Linux Mint 17.3 with Cinnamon. When I try to switch to custom resolution using xrandr, screen blinks and I see something like this in Xorg log (it is /var/log/Xorg.0.log for me):

[ 13767.590] (II) intel(0): switch to mode 1440x1080@60.0 on VGA1 using pipe 1, position (0, 0), rotation normal, reflection none
[ 13767.696] (II) intel(0): switch to mode 1920x1080@60.0 on VGA1 using pipe 1, position (0, 0), rotation normal, reflection none

So it actually changes mode (or at least tries to), but reverts it back immediately.

When I do all the same in an empty Xorg server (sudo Xorg :1 & xterm -display :1), everything works as expected. This means that the problem is not caused by Xorg or xrandr.

Most likely that is Cinnamon (its Gnome heritage, to be precise) trying to automatically configure monitors based on ~/.config/monitors.xml which is modified by "Display settings". I don't know how to prevent this interference, apart from not using Gnome.

Update: It so happened that I've been passing close to this question again, so I decided to re-check it. Two things:

  1. Most likely xrandr plugin of gnome-settings-daemon (cinnamon-settings-daemon in my case) is responsible, so disabling it should help. (I have a toggle for it at Settings>Startup applications right now, so I didn't look further into it. If the toggle is not present there should be other ways.)

  2. I cannot reproduce that problem at all at the moment, xrandr can now change modes just fine. That's Cinnamon version 3.6.7 (cinnamon-settings-daemon 3.6.2), not sure what the situation is with Gnome itself. My system setup is exactly the same as it was. (I even got the fried LCD replaced under warranty.)

  • As a side note, my specific problem has solved itself. I have just fried my LCD while trying to reduce blanking intervals to reduce video signal bandwidth to reduce noise caused by average quality VGA cable that I used to display FullHD. – EvgEnZh Mar 20 '16 at 5:36
  • No solutions, but the same problem. I think @EvgEnZh is on to something. I'm using the Gnome d/e for the first time and every time I start up, my display is set to the wrong resolution. I try to correct this using a script I wrote to autoconfigure my external display and ran into the same problem. I think it is Gnome, nothing else (I've had about a dozen different Linux distros, two versions of Windows, and two Android OS's on this thing) has had this problem. The only way around it I can think of is manually setting the resolution every stinking time I boot up, or just not using Gnome – Bus42 Jul 17 '16 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.