1

i have a Raspberry Pi 1 Model B with Raspbian / Linux raspberrypi 4.1.7+ installed.

I have two USB Adapter:

Bus 001 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

So the first Interface wlan0 should be able to access other WIFI AP regularly. This is not a problem. It works. But Interface wlan1 should start as an AP itself with the SSID: paketBox
No password required.

I tried different approaches but nothing worked so far. On my Laptop i can just click "Use as Hotspot" and then I can edit the Config Files (Fedora 22). Very easy and it works.

I tried to create a new Connection with nmcli following this: https://fedoraproject.org/wiki/Networking/CLI

my Hotspot config file at /etc/NetworkManager/system-connections looks like this:

[connection]
id=Hotspot
uuid=03620827-416a-49a2-ab1f-e7987c079cbe
interface-name=wlan1
type=wifi

[wifi]
ssid=paketBox
mac-address=74:da:38:5b:5c:2d
mode=ap

[ipv6]
method=auto

[ipv4]
method=shared

i restarted NetworkManager and then i tried:
sudo nmcli con up Hotspot ifname wlan1
the result was this:
Error: Connection activation failed: Connection 'Hotspot' is not available on the device wlan1 at this time.

So my question is the following: what am i missing? Does NetworkManager has other config files? I mean i would expect to just create a correct file at the correct position and to restart the NetworkManager. And it should just work.

ifconfig:

eth0      Link encap:Ethernet  HWaddr b8:27:eb:e0:eb:8f  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:6608 (6.4 KiB)  TX bytes:6608 (6.4 KiB)

wlan0     Link encap:Ethernet  HWaddr 74:da:38:54:79:bc  
          inet addr:192.168.178.72  Bcast:192.168.178.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:894 errors:0 dropped:1 overruns:0 frame:0
          TX packets:588 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:144069 (140.6 KiB)  TX bytes:80780 (78.8 KiB)

wlan1     Link encap:Ethernet  HWaddr 74:da:38:5b:5c:2d  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:1 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

edit: also did a sudo nmcli con reload (got no error) followed by a
sudo nmcli dev disconnect wlan1 (Error: Device 'wlan1' (/org/freedesktop/NetworkManager/Devices/3) disconnecting failed: This device is not active )
followed by:
sudo nmcli con up wlan1 (Error: neither a valid connection nor device given.)
and again, just to be sure: sudo nmcli con up Hotspot ifname wlan1
(Error: Connection activation failed: Connection 'Hotspot' is not available on the device wlan1 at this time.)

edit2: output of syslog after reinstalling raspian and setting up networkmanager. this time i tried also the adhoc mode. error: Error: Connection activation failed. here is the link to the snippet: syslog snippet

  • I think I have a very similar problem on my RasPi 2 with the same WiFi Dongle. Maybe NetworkManager has the same problem with this chipset as hostapd (see e.g. daveconroy.com/… or raspberrypi.org/forums/viewtopic.php?t=103825&p=717560 ), but I can't find a solution for NetworkManager. – luckyrumo Dec 19 '15 at 16:47
  • well until now i did not find any solution with networkmanager/nmcli. then i thought i should just go with hostapd for my wlan1 interface and let it be in the /etc/network/interfaces file. wlan0 is managed by network manager. i followed this howto: http://jankarres.de/2015/06/raspberry-pi-wlan-access-point-einrichten/ it is in german. but i think it is very clear. – malachi54 Dec 19 '15 at 20:36
  • Sure that's a possible workaround, but I'd really like to use NetworkManager, it's just so much easier... And I don't understand why it works with Ubuntu 15.04 on my notebook, but not with the newer Raspbian Jessie. Maybe I'll try to install some different OS on the RasPi, if I have time. – luckyrumo Dec 19 '15 at 21:29
  • well with hostapd it is not that hard. if you want i can send you some config files of mine. and a little script to "toggle" the service. but i understand you. i wanted the solution with network manager so it is just one package i need to run the system. but it is ok now with hostapd+networkmanager. – malachi54 Dec 19 '15 at 22:00
  • Thank you, but I'm quite sure I could do it with hostapd if I wanted too (the tutorial you linked above looks good, and I am german). I just found stackoverflow.com/questions/32703715/… and I will try that now :-) – luckyrumo Dec 19 '15 at 22:19
0

The description in the question on SO that I linked in my comment above actually worked on my RasPi 2 with Raspbian Jessie. I simply followed steps 0-4 there (changing step 3 as needed for the RasPi 2 hardware according to the official documentation) and then set up the access point with network manager.

I took all the settings for the latter from the access point I created with ubuntu on my notebook. In particular,

802-11-wireless-security.proto:         rsn
802-11-wireless-security.pairwise:      ccmp
802-11-wireless-security.group:         ccmp

seem to be somehow important for WPA.

However, the downside might be that you probably have to do all the compiling again every time a new kernel version is released.

  • i won't try this solution (since really no time and the project is actually finished). but if you say it worked for you i guess i should accept this answer for now – malachi54 Dec 20 '15 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.