2

I recently decided that I will no longer use Ubuntu and give Arch Linux a shot.

I did everything according to the Beginner's guide on Arch Wiki, which worked. Next I wanted to install the Cinnamon Desktop and GDM.

When GDM is launched it only gives the seemingly infamous "Oh no, something has gone wrong" error message.

I suspect this might be a graphics driver/Xorg-related problem.

Here are my specs:

  • Processor: Intel i7-3537U
  • Graphics: Intel HD Graphics 4000 /// Nvidia GT 750M
  • Installed drivers include: xf86-video-nouveau and xf86-video-intel
  • UEFI boot (secure boot disabled)

/var/log/Xorg.0.log contains the following content: http://pastebin.com/AspftGNf

  • hey thanks for that info, how can i uninstall nouveau? pacman -Sr xf86-video-nouveau gives an error message, something about aplm library not being loaded. – Alex Dec 6 '15 at 21:15
  • That's strange because i previously installed it via pcaman -S xf86-video-nouveau.So you suggest to exactly add the line given by you to /boot/grub/menu.lst ? Just want to be sure :) – Alex Dec 6 '15 at 21:29
  • Thanks again for that info. Two more things. I'm really puzzled now. I cannot find any /boot/grub directory. On my root partition /boot is empty and on my efi-partition there is only a directory efi. So where is grub? And the other thing is which driver would you recommend me for my graphics card? – Alex Dec 6 '15 at 21:50
  • oh not sure how this works exactly. I did the following steps: bootctl install (part of systemd), then created a boot entry in /boot/loader/entries/arch.conf containing information about linux kernel and initrd. Next i saved the default etry in /boot/loader/loader.conf. – Alex Dec 6 '15 at 22:07
3

I was able to solve my problem, using kde5 plasma and sddm though. pacman -S mesa-libgl solved my problem (replacing the nvidia-libgl). If anyone knows why this works feel free to comment.

  • I got a similar error on a Kali Linux hard drive that was installed on one machine, then moved to another. In my case, the two machines were using different graphics cards. Although both were Nvidia, they were significantly different in age and likely used different binary graphics drivers. When you swapped out the libgl, you probably forced the system to reevaluate the graphics card installed. For me, I had to switch the nvidia graphics driver I was using manually – computergeek125 Mar 25 '18 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.