0

I just upgraded from Linux Mint 14 to 17.2 and Thunderbird 38.4.0 is having problems. It can't resolve any host names except those in /etc/hosts. Everything else I've tried, including Firefox, the host command, ping, etc. works fine.

If I add my mail server host name to /etc/hosts, it works. Without it, it fails to connect. It also can't connect to the Mozilla sites such as the add-ons site.

I created a new user, logged in as that user, and tried to set up Thunderbird. It failed in the same way, unable to resolve host names.

I tried disabling ipv6 in the Thunderbird config editor but that made no difference.

Proxy settings are set for no proxy.

/etc/resolv.conf is correct. /etc/nsswitch.conf has:

hosts: files mdns4_minimal [NOTFOUND=RETURN] dns

Changing it to just files dns makes no difference.

strace shows that Thunderbird is reading /etc/resolv.conf and sending DNS queries. tcpdump shows the DNS queries and results. But, there are no attempts to connect to the mail server hosts.

Any ideas?

Updated:

This appears to be a network configuration problem. I tried to move over my network setup from Linux Mint 14 but appears enough has changed that it doesn't work anymore. If I remove the static network configuration from /etc/network/interfaces and just let it use DHCP, everything works.

Here's what I added to /etc/network/interfaces:

iface eth0 inet static
        address 192.168.0.4
        netmask 255.255.255.0
        gateway 192.168.0.1
        dns-nameservers 192.168.0.1 192.168.1.254 8.8.8.8

auto eth0

When that's removed (and the system rebooted), /etc/resolv.conf shows just a single DNS server at 127.0.1.1, which appears to be some built-in DNS server. I don't know how that makes a difference, but it does.

What's the correct way to configure Linux Mint for a static IP address?

  • does the /etc/resolv.conf look life this: nameserver 192.168.0.1? does the static configuration also has problems with network 192.168.0.0 added? do you have a route for 192.168.1.254? It is not in your network can you provide output for route? – syss Dec 7 '15 at 9:43
  • When I add the /etc/network/interfaces entries listed above, /etc/resolv.conf has a corresponding nameserver entry. Without those entries, /etc/resolv.conf lists only 127.0.1.1. Routing is not a problem; both ping and Firefox are able to access external sites. – Bill Shannon Dec 7 '15 at 20:44
0

I finally figured out that there's two different network configuration editors.

One is invoked by right clicking on the network connection icon in the tray, and invokes nm-connection-editor. This changes configuration information in /etc/NetworkManager. Using this one I was able to successfully configure a static IP address and DNS servers and Thunderbird works fine. This uses dnsmasq, which causes all DNS requests to go through a local server instead of directly to the DNS server.

The other one is invoked by the System > Administration > Network menu item in the old Mint menu. This invokes network-admin, which makes changes to /etc/network/interfaces. This is the configuration information that I had moved over from Linux Mint 14. While this seems to work for most things, this is the configuration that caused Thunderbird to fail to access hosts looked up through DNS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.