here's the deal. I had installed this afternoon pulse audio manager for trying to fix a no sound issue with an HDMI cable, the issue wasn't solved so I figured out I wouldn't need pulse audio manager since Mint has alsa as default, so for avoiding possible conflicts I uninstalled pulse audio manager by just right clicking on the Cinnamon menu. After that I did a reinstall of alsa since it wasn't properly recognizing my headphones when plugged in and thus playing music in my laptop speakers and headphones at the same time. So here's when it gets really good, I reboot my laptop and behold this message:

Your session only lasted less than 10 seconds. If you have not logged out yourself this could mean that there is some installation problem or that you may be out of diskspace. Try logging in with one of the failsafe sessions to see if you can fix this problem.

And then this 'details' message appeared in a box

mdm[2038]: GLib-CRITICAL: g-key-file-free: assertion 'key file !=NULL' failed

So far I have tried Clem's solution for manjaro , installing lightdm, reinstalling grub (stupid move since it has nothing to do with MDM), reinstalling MDM, forcing MDM's reload and nothing has worked, I still get no access to my DE. I can only work from the TTY. Again I'm using Linux Mint 17.2 Cinnamon and so sorry for the bad English, it's 3 am here and I've been battling with this issue for five straight hours. Note: I'm not out of diskspace since I have more than 100 GB of free space, I've checked this when reinstalling grub using the Gparted installed within Boot-Repair-Disk

Please help

1 Answer 1


Have the same problem!

The solution: Ctrl+Alt+F1 then login and:

sudo apt-get install cinnamon
sudo reboot
  • I had this same error after upgrading from Mint 17.3 to Mint 18. Installing cinnamon fixed my issue. Jul 21, 2016 at 3:08
  • I already had cinnamon installed prior to the upgrade, so the above suggestion has no effect. Has anyone found an alternate solution?
    – Lou
    Aug 8, 2016 at 21:16
  • Found and fixed my issue. Looks like my session failure was related to the dnvm.sh script for .Net core. For any one else having the same problem here's where I found my answer unix.stackexchange.com/questions/217487/…
    – Lou
    Aug 8, 2016 at 21:51
  • Thx a lot, it was not quite obvious to install cinnamon given that error message. It helped and saved a lot of time propably!
    – colidyre
    Jun 22, 2018 at 17:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .