1

I just bought msi gs40 6qe. This laptop has skylake core i7 6700hq (which means integrated graphic HD 530) and discrete GTX 970. I'm struggling to start xorg on archlinux.

I'm trying to run xorg withing nvidia and nvidia-libgl packages as it described on wiki with modesetting. I added those ~/.xinitrc:

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

I also have the same xorg.conf as on wiki. But when I start xorg I get black screen.

[    9.205720] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  358.16 

Here'are my, xorg.log, and dmesg (those one with started sddm configured to plasma5 and modesetting). I'm installing up to date archlinux with 4.2.5-1 kernel with this patch. (Thus I got rid of this pci device is not a vga device message in kernel log.

Any kind of help is greatly appreciated. If you need any other configs or logs just tell me.

EDIT:

  • Well, starting X first and then setting provider from another tty changed everything. Now Screen goes totally black(no backlight), until I set provider from tty2. Here's listproviders, tty output and xorg.log At least I got something....

  • Here's xorg.log if I set modprovider in ~/.xinitrc and startx. Xorgs terminates with 0 right after start.

  • Here's xorg.log with sddm and modeset in sddm/Xsetup - Screen goes black without backlight
0

The black screen is x running properly. Without a .xinitrc file, when x starts nothing else is started to it is just a black screen. In order to start a window manager like twm and try it just pacman -S xorg-twm and then put exec xorg-twm in your ~/.xinitrc file and start x.

This can by any WM you want, my .xinitrc just has

exec awesome

so its likely a problem with the WM

  • X runs properly with blackscreen if backlight is on and there's black image. In my case backlight is off. I have installed xorg-twm and xclock should start since it drawing is set in /etc/X11/xinitrc by default. If I remove xclock I'll get no such programm error. – deathangel908 Dec 8 '15 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.