My system crashed and even though I haven't been able to know what caused the crash after going through the usual logs: messages, dmesg, secure, etc. There's nothing valuable I have seen on them so I decided to follow a tutorial in how to run the crash application to see what might have happened.

Every time I run it with:

$ sudo crash System.map-3.10.0-123.el7 vmlinuz-3.10.0-123.el7 vmcore

I get the following error: crash: vmlinuz-3.10.0-123.el7: not a supported file format

Here's the output:

crash 7.0.9-5.el7_1
Copyright (C) 2002-2014  Red Hat, Inc.
Copyright (C) 2004, 2005, 2006, 2010  IBM Corporation
Copyright (C) 1999-2006  Hewlett-Packard Co
Copyright (C) 2005, 2006, 2011, 2012  Fujitsu Limited
Copyright (C) 2006, 2007  VA Linux Systems Japan K.K.
Copyright (C) 2005, 2011  NEC Corporation
Copyright (C) 1999, 2002, 2007  Silicon Graphics, Inc.
Copyright (C) 1999, 2000, 2001, 2002  Mission Critical Linux, Inc.
This program is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions.  Enter "help copying" to see the conditions.
This program has absolutely no warranty.  Enter "help warranty" for details.

crash: vmlinuz-3.10.0-123.el7: not a supported file format


  crash [OPTION]... NAMELIST MEMORY-IMAGE[@ADDRESS] (dumpfile form)
  crash [OPTION]... [NAMELIST]                  (live system form)

Enter "crash -h" for details.

I'm using CentOS 7. What might be wrong? And also, Any ideas how to get better information about the crash would be appreciated.


The vmlinuz format is compressed AFAIK. The steps are too long to copy-paste here, so I'm gonna provide a link instead.


|improve this answer|||||
  • I tried that link already and I noticed that my vmlinuz is not compressed as the one in the post. – VaTo Dec 5 '15 at 17:33
  • Well yeah. The link was Ubuntu and you're using CentOS. Not sure if the headers are the same. I assumed you were gonna check :) Try using tar, gunzip, unzip, bzip2 -dk [file], or whatever decompressor you have installed. I recommend going for bzip2 first. – PNDA Dec 6 '15 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.