1

I'm trying to run gnome-terminal in several containers on my machine (I'd like to run gnome-terminal from my ssh to the container), and on some of them it works fine, on others it fails silently (with error code 1) unless I run as root (sudo gnome-terminal).

I'm running Ubuntu 14.04.3 LTS on all containers

I tried to set up the containers to be as alike as possible since I'm using them to test my software with different versions of the database. But as I was learning as I went, even after I clones some, I had to add packages as I went and found I needed them. So there are no doubt some differences.

I don't know (and couldn't find) any information about determining what error caused gnome-terminal to fail.

I've checked through stack-exchange (and Googling in general) for information on gnome-terminal failing, but most of what I found was from people staring it from a menu, and getting advice on starting it from the command line to get more information. I'm already starting it on the command line, but can't figure out where to find why it is failing.

In either case, I get these warnings. Since I get them in containers that work and ones that don't, I doubt they are pertinent to the problem, but I include them in case they are somehow related.

** (gnome-terminal:856): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-mU1Tr7vgjH: Connection refused

(gnome-terminal:856): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:63:17: Theming engine 'unico' not found Gtk-Message: Failed to load module "canberra-gtk-module"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.