3

I've a Asus ROG laptop that came with Windows 8.1 preinstalled, I upgraded it to Windows 10 and then I wanted to install Bunsenlabs Linux as dual boot. The laptop was UEFI locked and it took me some time to figure out how to get it to boot from a USB. I ended up installing Bunsenlabs via legacy boot, after supposedly successfully installing the whole system, after the reboot it still loaded a Windows loader when selecting my hard drive as boot option. I then installed a UEFI version of Grub using boot repair disk. Now I can boot everything correctly (I set boot back to UEFI), but I can't shutdown Windows, when selecting shutdown it only logs me out of my account. I've to shut it down via ACPI... That wouldn't be a problem, since Windows doesn't even detect it as a forced shutdown (or at least it doesn't give out any warnings on the next boot) but I'm unable to access my NTFS partition where I store a lot of data.

  • 1
    I'm voting to close this question as off-topic because it is about windows. – maxschlepzig Dec 3 '15 at 19:40
  • I know it's about Windows. But I'm pretty sure that it's a problem generated by Grub2. And therefore by a Linux system – Steffen B Dec 3 '15 at 19:45
  • shutdown ... "locks me out of my account" or "logs me out of my account"? – roaima Dec 3 '15 at 19:58
  • @roaima logs. Sorry for the typo. It just works like the log-out option. Linux also seems to shutdown a bit fast... It doesn't even take 5 seconds. (It's the first time I ran Linux on a "high end" system. I'm not sure if that's normal neither.) – Steffen B Dec 3 '15 at 20:04
  • "I ended up installing Bunsenlabs via legacy boot" and by extension unable to boot Windows. Reinstall using secure boot. – Braiam Dec 3 '15 at 20:38
4

This issue is faced by many users using dual boot win10/linux. GRUB seems to have some incompatibility with windows 10 fast boot process. Win 10 default shutdown does not actually shut down the whole system instead it saves computer's system files to a hibernation file which helps win 10 to boot faster the next time you power on your system. More info about win 10 fast startup

I faced this issue and overcame this problem by disabling the win 10 fast boot process.

Steps to disable fast startup:

  1. Go to control panel.

  2. Find power options.

  3. From the left menu click on "Choose what the power button does".

  4. Click on "Change settings that are currently unavailable."

  5. Go to the bottom of the page, uncheck "Turn on fast startup" and save changes.

This will resolve win 10 shutdown problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.