0

everyone!

As the question suggests, I'm finding it difficult to boot Kodibuntu from grub2. Here's the whole story:

I have recently bought an Intel Compute Stick which so far has been great for my purposes but I want to dual boot Windows 10 and Kodibuntu from it. I already have Windows 10 installed, obviously.

I went on and downloaded the Kodibuntu ISO from the official website, and burnt it on a USB stick with LiLi. Needless to say, it didn't boot on my Intel Compute Stick. I checked all the setting in the bios, everything was just fine. Tried using UNetBootIn and Universal USB Installer to create the USB and both failed. I then tried booting off the stick on my laptop which worked fine and therefore, the problem isn't with my usb/iso, it's with the Intel Compute Stick.

Next, I burnt an Ubuntu iso to the stick and I wasn't surprised to see that it booted from it flawlessly on the Intel Compute Stick so I concluded there must be some compatibility between the Bios on the Compute stick and Kodibuntu. Since the bios won't boot it and I could enter the grub console from the ubuntu live usb, why not boot kodibuntu from grub. It is, after all, the universal boot loader.

I then took a look at the file structure of the kodibuntu iso which is as follows:

|----md5sum.txt
|   
|---.disk
|       casper-uuid-3.13.0-43-generic
|       info
|       
|---casper
|       filesystem.manifest
|       filesystem.manifest-remove
|       filesystem.size
|       filesystem.squashfs
|       initrd.lz
|       vmlinuz
|       
|---isolinux
|       adtxt.cfg
|       boot.cat
|       exithelp.cfg
|       f1.txt
|       f10.txt
|       f2.txt
|       f3.txt
|       f4.txt
|       f5.txt
|       f6.txt
|       f7.txt
|       f8.txt
|       f9.txt
|       isolinux.bin
|       isolinux.cfg
|       menu.cfg
|       prompt.cfg
|       splash.png
|       stdmenu.cfg
|       txt.cfg
|       vesamenu.c32
|       
|---preseed
     ubuntu.seed

It isn't exactly the same structure as an Ubuntu live ISO, as you can see. I placed the kodibuntu files onto a partition on the storage of the compute stick and from the grub console I tried setting the root to that partition and then setting linux and initrd accordingly but it when trying to set the linux it always told me "wrong magic number" whatever that means. I then moved the Kodibuntu files onto the usb and tried doing it from there. Same magic number thing.

After that failed, I decided to add an entry for Kodibuntu in the grub config of the ubuntu live usb.

menuentry "KODIBUNTU" {
    linux   /KODIBUNTU/casper/vmlinuz file=/KODIBUNTU/pressed/ubuntu.seed
    initrd  /KODIBUNTU/casper/initrd.lz
}
menuentry "KODI2" {
    set isofile="kodibuntu-14.0-helix_amd64.iso"
    loopback loop (hd0,1)$isofile
    linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=$isofile noprompt  noeject
    initrd (loop)/casper/initrd.lz
}

I placed the kodibuntu files into a folder named "KODIBUNTU" right in the root of the USB drive.

As you can see I tried 2 different entries and both of them loaded something and then threw me at the BusyBox console.

So, any ideas how I can boot kodibuntu from grub? I'd really appreciate your help.

(Also, I don't want to install any other linux distro and then install Kodi on top of it. I want a fresh install of Kodibuntu alone.)

0

I found a solution. I've replaced all files from the Ubuntu live USB with the files from the Kodibuntu live USB and in the grub confing, replaced "vmlinuz.efi" with "vmlinuz". Booted from the usb, selected "Install Ubuntu" from the grub menu (I was too lazy to change the text of the menu entry) and it fired Kodibuntu like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.