0

I'm trying to upgrade SLES 11.3 to 11.4 with zypper using the following instructions: https://www.suse.com/documentation/sles11/book_sle_deployment/data/sec_update_sle11sp3.html

After launching the following command: zypper dup --from SLE11-SDK-SP4-Pool

I get the following 3 problems:

Problem: nothing provides yast2 >= 2.17.140 needed by yast2-dns-server-2.17.24-1.2.noarch
Problem: nothing provides yast2 >= 2.17.140 needed by yast2-ca-management-2.17.27-1.1.noarch
Problem: nothing provides product(SUSE_SLE) = 11.4 needed by sle-sdk-release-SDK-11.4-1.55.x86_64

Problem: nothing provides yast2 >= 2.17.140 needed by yast2-dns-server-2.17.24-1.2.noarch
 Solution 1: Following actions will be done:
  deinstallation of yast2-dns-server-2.17.23-0.5.1.noarch
  deinstallation of yast2-dhcp-server-2.17.6-0.4.2.21.noarch
 Solution 2: keep obsolete yast2-dns-server-2.17.23-0.5.1.noarch
 Solution 3: break yast2-dns-server-2.17.24-1.2.noarch by ignoring some of its dependencies

What should I do?

0

You probably need to additonally specify the non SDK repo with your zypper dup like so:

zypper dup --from SLE11-SDK-SP4-Pool --from SLES11-SP4-Pool

Background:

Problem: nothing provides product(SUSE_SLE) = 11.4 means the main SLES 11.4 product itself cannot be found. Use a command like zypper search --details SUSE_SLE to see which of your repositories may contain the missing package or product.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.