I am entirely new to Linux as I just installed the dual boot of Windows 10 and Fedora. And the problem I ran into is that in the network setting, there is no option for WiFi? I did intensive Google search and yield no good result. None of the installing packages from the terminal seemed to work... Maybe I should switch to a different distro?

image after running lspci: image

  • 2
    Have you read the documentation? Also, what WiFi adapter are you using? Switching distros will probably not make a difference. Add details to your question :-) Dec 3, 2015 at 6:41
  • yeah, I read some parts of docs and it did not help. And also I am using Broadcom 802.11n Network Adapter Dec 3, 2015 at 15:26
  • @garethTheRed for some reason, gcc and a lot of other packages don't even come with it... Dec 3, 2015 at 23:44
  • I'm sure you'll be able to install gcc - once you've got wireless working. There are many Broadcom adapters - run lspci in a terminal and post that as an edit to your question. Broadcom isn't the best chipset for Linux support. Dec 4, 2015 at 16:29
  • 2
    There seems to a few options open to you, but they'll all involve downloading extra packages. Google 'fedora BCM4312' and you'll see a few. Try to keep to the latest ones as things change at quite a pace so a 4 year old blog might not be relevant any more. Try not to use ndiswrapper if you can help it. Fortunately, you have an ethernet adapter so you can use that to download the extra packages. Dec 4, 2015 at 17:32

2 Answers 2


Fedora updates regularly break the functioning of Broadcom wireless devices. That's very annoying.

I have a HP laptop with a Broadcom BCM43228 wifi card. The following, taken from this blog post, worked for me:

wget http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm
wget http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
rpm -iv rpmfusion-free-release-23.noarch.rpm
rpm -iv rpmfusion-nonfree-release-23.noarch.rpm
dnf clean all
dnf install akmod-wl kernel-devel
akmods --force

(If the last command gives you an error "Building and installing wl-kmod failed", it might be that you have installed the wrong architecture for the package akmod-wl. In this case, do the following:

dnf remove akmod-wl
dnf install akmod-wl.x86_64 

and retry the akmods --force command.)

Then do:

modprobe wl

The wlo1 wireless interface should be visible now. If it doesn't, do a systemctl restart NetworkManager.

  • Correction: Broadcom drivers (as written by Broadcom) are broken, and tend to make your system misbehave. Use the drivers that come with your kernel.
    – vonbrand
    Jan 6, 2016 at 16:17
  • @vonbrand Post edited :)
    – dr_
    Jan 6, 2016 at 17:15
  • @dr01 I've tried this and it did not work for me.. modprobe wl gives me an error of could not insert 'wl': required key not available Jan 10, 2016 at 22:17
  • Did the command akmod finish successfully?
    – dr_
    Jan 11, 2016 at 10:16

I believe Fedora ships with NetworkManager. You should be using the nmcli command to check the status of, and make changes to, your wireless connections in most cases. Here is the official documentation for nmcli: https://fedoraproject.org/wiki/Networking/CLI

There is a section specific to Wifi. Also, check the compatibility of you wireless device with Linux. If there is a module available from the manufacturer you might have to manually install it. Best of luck, and welcome to Linux!

  • You are right, Fedora sports NetworkManager for quite a few releases now. Works like a charm.
    – vonbrand
    Jan 6, 2016 at 16:16
  • @vonbrand , can you describe the steps you follow? i'm running into the same issue
    – Kassav'
    Aug 30, 2016 at 12:59
  • I also need the steps of solution, could you please explain how? @vonbrand Sep 18, 2016 at 5:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .