0

I have a Debian media server which seems to be crashing several times daily for no apparent reason at all. It simply freezes up, without restarting, until you manually restart it. I have uploaded the syslog here and the kern.log here Any restart indications in the log file were done manually by me and not as a direct result of the crash.

4
  • Post your logs to pastebin, I would rather not download a file
    – cutrightjm
    Dec 3 '15 at 4:24
  • Just updated the links.
    – hmnd
    Dec 3 '15 at 4:35
  • Have you looked at all of the things that say "temperature alarms"? That might not be the answer, but it's a good thing to look in to at least
    – cutrightjm
    Dec 3 '15 at 4:40
  • I thought that as well. But it seems as though that sensor in particular is a virtual sensor created by lm-sensors since it always stays at 127.0°C. So it doesn't seem to be an overheating problem.
    – hmnd
    Dec 3 '15 at 5:06
2

I don't see any explicit question here, but here's what I would do to start debugging this issue.

The first thing I do in cases like this is to run memtest86 or memtest86+ a few hours on the machine. This will rule out a lot of the common hardware errors.

If that passes, I run mprime for good measure. It will check that the CPU continues to calculate most things correctly under stress. I've had subtle errors after several hours running this, although I have not had to use it in a couple of years.

Now, if these tests passes, your hardware and cooling should be fine. After this I'd try running the system from a live CD if possible, perhaps trying an i386 version instead of amd64, to see if there's something wrong there.

If this does not give any insight, feel free to update the question with any new information!

5
  • There have been regular complaints about instability in Debian 8, specially from the ARM community mainly due to buggy wifi cards and temperature issues. I would uninstall all the fluff, like avahi, and upgrade to the latest kernel 4. At least, that is what I did at home. Dec 3 '15 at 7:58
  • The computer in question is not running on ARM hardware.
    – pipe
    Dec 3 '15 at 8:38
  • After checking the logs to verify the CPU model I see that he is using nouveau. I have had massive problems with that on a more recent kernel. I would comment on the original post, but alas, I don't have enough virtual points here.
    – pipe
    Dec 3 '15 at 8:48
  • pipe, write the answer and I will give you points. Dec 3 '15 at 8:51
  • @pipe I ran a memtest overnight, 0 errors. So do you think I should upgrade to the latest kernel, or do you have any other suggestions?
    – hmnd
    Dec 3 '15 at 22:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.