1

I used the top answer here How do I reduce the size of locale-archive? because I wanted to free up a little space.

Now my web server is down and I can't get build-locale-archive working.

First error I get it is build-locale-archive: cannot read archive header

When I copy the locale file from my other server I get this...

build-locale-archive: incomplete set of locale files in "/usr/lib/locale/tmp

And then build-local-archive brings my file to zero file size:

root root 0 Dec 1 22:03 locale-archive.tmpl

That /tmp directory is from some instructions I found in Google to recover from this error by downloading glibc-common-2.12-1.166.el6_7.3.x86_64.rpm, but apparently I'm missing something.

2

This gave me the idea to just reinstall glibc-common http://hpc.mtech.edu/scyld-doc/administration-guide/x3137.html

yum reinstall glibc-common

That didn't work, but then I was confident I had the right "goodies" and it was just my tinkering that was the issue.

build-locale-archive still choked on the temporary directory that I had, so I just did rm -rf /usr/lib/locale/tmp and then build-locale-archive worked.

Then I restarted nginx and mysql, but I was still offline. I had to reboot the system. Then it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.