0

I installed Manjaro on VirtualBox to try it out as a replacement to my current distro.

So I installed Eclipse and started it up from the command line (i.e. ./eclipse) and I can see the following: enter image description here

Why are Eclipse buttons are having a black background !

I also had another issue but its resolved now and I'm not sure why. When I open the Preferences menu, no matter what section I choose whether its Java, General, Web..etc, only the General main dialog is shown.

So I chown -R root:root the whole eclipse folder (as this solved a similar issue before on Ubuntu), opened eclipse, the same Preferences dialog behavior persists, but then I switched windows to do something else (after clicking on a preference section other than General, came back to eclipse after a short while, and found that the Preferences dialog issue is solved ! Has anyone seen anything like that ? Is it ok to chown the whole eclipse folder to root ? Why would this be a solution ?

0

I figured out how to resolve the black buttons thing. I went to Appearance dialog available in the Settings application in Manjaro, and selected a different style other than Menda which was set then. Just click on a style and whole appearance of Eclipse will reflect the changes, then just click Close on the Styles dialogue when you are done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.