3

I'm having an issue with Mint XFCE 17.2 detecting my laptop's internal microphone as a stereo microphone at a hardware level. The problem is that, since it's a mono device, the microphone's "right channel" is complete static:

Recording audio in Audacity shows a blown-out right channel

As I've come to find out, the non-existent right channel is "floating", and when its signal hits the amplifier it gets amplified into static. I've discovered that it's possible to silence the right channel via PulseAudio, but this leads to weird things like my voice only coming in on the left side during Skype calls.

How do I get PulseAudio (or maybe alsa at a lower level) to see that the microphone is a mono input? Is it possible to somehow tweak the audio drivers?

And I have tried creating a virtual source that maps the mic to a mono source:

# Added to /etc/pulse/default.pa
load-module module-remap-source master=alsa_input.pci-0000_00_1b.0.analog-stereo source_name=mono_mic channels=1 master_channel_map=left channel_map=left

This successfully created a second mono input that seems to work fine in Skype/etc...:

So long as I keep that right channel silenced, it works fine

But I'm not happy with this virtual input since I still have to keep the right channel on Silence on the hardware device itself. In addition, when I try to adjust the hardware device's left channel levels via PulseAudio, for some stupid reason (a bug perhaps?) Pulse automatically locks both channels, which causes the right channel to snap to the left channel's levels. This is despite my turning off channel locking beforehand. I then have to manually disable the channel lock and set the right channel back to Silence.

In the end I'd prefer to fix the underlying issue and get the microphone properly recognized as a mono input. Any advice?

  • You have a source of true randomness on your computer? Pipe it into /dev/random or /dev/urandom/ via udev, and you can expect much better random performance! (On a serious note, just keep the hardware device's left channel at 0dB and change the volume on the virtual one.) – wizzwizz4 Mar 13 '16 at 15:32
0

You do not say what make and model of laptop, how old is it? this would be of help in providing a solution. But you should try a separate stereo mic plugged into the 3.5 jack socket and lock the channels together in the audio setting window. Then monitor the output to headphones to avoid howl round. This should be a noise free combined left and right output. Reverting to the internal stereo mic to see if the problem returns, this would show you if there is a faulty internal mic or not. Removing the pulse audio and Reloading it may clear the problem. if not the internal mic is at fault. Another check is to use an internal recorded voice into left and right of the mic, and play it back. What does it sound like? \\skype has been full of problems within Linux due to Microsoft meddling with the app. Best wishes Peter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.