0

I installed Fedora23 on a GPT partition(also chose LVM option).

There is no option now for Ubuntu on the GRUB list when I boot normally (without interfering). However, if I hit F9 on bootup and go into boot options, I see

Fedora(Toshiba MQ01...)
Ubuntu(Toshiba MQ01..)
Boot From EFI File

I can boot from here to Ubuntu by selecting Ubuntu or going into the EFI(grubx64.efi).

I ran update-grub from Ubuntu.
I also followed the instructions from Fedora Wiki.

When I run grub2-mkconfig -o /boot/grub2/grub.cfg, I can see Ubuntu 14.0.. on /dev/sda5

Found linux image: /boot/vmlinuz....
Found initrd image: /boot/initramfs-4.....
Found Ubuntu 14.04... on /dev/sda5

But I don't have an Ubuntu option to boot.
What can I change to have the options for both Fedora and Ubuntu?

Edit
As suggested by clearkimura, I ran update-grub in Fedora first.

  • Generic advice: The boot loader on the first partition (or where it was installed at first time) should be updated, and not the boot loader in other partitions. Here, I assume Fedora was installed first? Then boot loader in Fedora should be updated instead. – clearkimura Dec 1 '15 at 19:46
  • Can you post the contents of your /boot/grub/grub.cfg file (Ubuntu might relocate it to somewhere in /boot/efi/, not 100% sure as Ubuntu isn't my speciality)?. Also, what partitions are each of the distributions on? – Joe Dec 2 '15 at 0:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.