A while ago I could plug in my Canon EOS via USB and it would get mounted as an external drive. Nothing has been reconfigured in the camera, but now if I plug it in

$> dmesg
[103943.225623] usb 1-2: new high-speed USB device number 2 using xhci_hcd
[103943.430666] usb 1-2: New USB device found, idVendor=04a9, idProduct=3110
[103943.430673] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[103943.430677] usb 1-2: Product: Canon Digital Camera
[103943.430680] usb 1-2: Manufacturer: Canon Inc.

$> ls /dev/sd*
/dev/sda  /dev/sda1  /dev/sda2  /dev/sda3  /dev/sda4  /dev/sda5  /dev/sda6  /dev/sda7  /dev/sdb  /dev/sdb1  /dev/sdb2  /dev/sdb3

sda and sdb are internal disks. Previously the camera would show up as sdc. Presently, other USB devices show up as sdc and are mounted correctly.

It works fine with Windows, I just plug it in and turn the camera on and it shows up as a removable drive.

What has gone wrong between dmesg and /dev? I think this broke after upgrading to Ubuntu 15.10.

EDIT: With thanks to telecoM for some progress, the issue is now this:

I did apt-get install gphotofs successfully. Now if I start from scratch by plugging in the camera and turning it on again, this is my experience in the shell:

#> dmesg
[37037.938598] usb 3-3: new high-speed USB device number 5 using xhci_hcd
[37038.159215] usb 3-3: New USB device found, idVendor=04a9, idProduct=3110
[37038.159222] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[37038.159226] usb 3-3: Product: Canon Digital Camera
[37038.159229] usb 3-3: Manufacturer: Canon Inc.
#> mkdir /tmp/mycamera
#> gphotofs /tmp/mycamera
#> ls /tmp/mycamera
ls: reading directory '/tmp/mycamera': Input/output error
#> mount | grep mycamera
gphotofs on /tmp/mycamera type fuse.gphotofs (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
#> fuser -u /tmp/mycamera

The GUI utility gtkam does find my camera in the list when I press the Detect button in the Add Camera dialog, but then I get a popup:

Could not initialize camera.

  • USB disconnect, device number 2, that does not look very promising.
    – A.B.
    Commented Nov 29, 2015 at 18:04
  • Yeah I pulled it out
    – spraff
    Commented Nov 30, 2015 at 20:37
  • You should be asking this question on askubuntu.com
    – Rob
    Commented Jan 22, 2018 at 12:59
  • Here is a mailinglist exchange for a camera with same id 04a9:3110. So in your place, I'd try gphoto2 --auto-detect and gphoto2 -L and see what happens ...
    – dirkt
    Commented Jan 27, 2018 at 20:55

1 Answer 1


Does the camera need to be in a specific mode in order to be detected as a storage device?

The messages listed only indicate that a generic USB device has been detected: it's saying nothing about detecting it as a storage device.

The idProduct and idVendor values indicate the camera model would be Canon EOS Digital Rebel XTi.

This post in the photography StackExchange may offer clues: https://photo.stackexchange.com/questions/42035/how-can-i-transfer-pictures-from-my-canon-digital-rebel-xti-400d-to-my-mac

It looks like most Canon DSLRs use PTP (Picture Transfer Protocol) instead of generic USB storage protocol, and only some cameras offer the option to switch to USB storage mode. Unfortunately Digital Rebel XTi is not among them.

To download pictures from the camera using PTP in Linux, you'll need the libgphoto2 library and related tools. There seems to be a gphotofs package that allows mounting a PTP camera for generic filesystem access. Is it possible that this package was installed before your OS upgrade, but got uninstalled in the upgrade process?

  • Thanks, this looks like a step in the right direction, but we're not quite there. Please see my edited question.
    – spraff
    Commented Jan 22, 2018 at 12:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .