1

I am aware I can use 'autostart' package.

However there are certain programs (e.g. 2 windows of Dolphin) which start automatically despite they're not in autostart.

Also, certain program fail to run effectively blocking others (as explained at https://unix.stackexchange.com/questions/244462/why-does-linux-mint-17-2-ubuntu-14-04-based-kde-occasionally-fails-to-autost ).

So, how do I manage manually which programs should run on Linux Mint (17.2 in my case) startup?

1

On ArchLinux, with KDE, there is this way, or that way. I suppose it works with Mint too.. You can check in /etc/xdg/autostart/ or ~/.config/autostart/ for example.

|improve this answer|||||
  • are those symlinks? – dragonmnl Dec 7 '15 at 19:19
  • No, they are directories... Everything in /etc is for your system configuration, and everything in ~/.config are for your personnal configuration. If you are the only user of your system, it doesn't matter which you choose. You can access these by the terminal, and put there the desktop files of the applications you want to autostart. Read the articles on Arch wiki to learn more about that. – Félicien Dec 11 '15 at 15:30
  • actually their content is different (and I'm the only user). Furthermore there are apps (e.g. Dolphin and Konsole) which run whether they're in those directories (or autostart) or not – dragonmnl Dec 12 '15 at 16:29
  • Have you check in KDE settings, that your session is not restored when you log in ? If yes, you can tell KDE which applications you don't want to be restored, I think. – Félicien Dec 15 '15 at 8:57
  • where do I actually find KDE settings? – dragonmnl Dec 15 '15 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.