2

I'm trying to install ssh2 for PHP in RHEL.

But it required libssh2-1.4.2-2.el6.x86_64.rpm and libssh2-devel-1.4.2-2.el6.x86_64.rpm.

So I downloaded and tried to install, I got below errors

# rpm -ivh libssh2-1.4.2-2.el6.x86_64.rpm libssh2-devel-1.4.2-2.el6.x86_64.rpm
warning: libssh2-1.4.2-2.el6.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 79ea5ed4: NOKEY
Preparing...                ########################################### [100%]
        file /usr/lib64/libssh2.so.1.0.1 from install of libssh2-1.4.2-2.el6.x86_64 conflicts with file from package libssh2-1.4.2-1.el6_6.1.x86_64

The output of yum info libssh2

Installed Packages
Name        : libssh2
Arch        : x86_64
Version     : 1.4.2
Release     : 1.el6_6.1
Size        : 318 k
Repo        : installed
From repo   : rhel-x86_64-server-6
Summary     : A library implementing the SSH2 protocol
URL         : http://www.libssh2.org/
License     : BSD
Description : libssh2 is a library implementing the SSH2 protocol as defined by
            : Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
            : SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
            : SECSH-DHGEX(04), and SECSH-NUMBERS(10).

Available Packages
Name        : libssh2
Arch        : i686
Version     : 1.4.2
Release     : 1.el6
Size        : 124 k
Repo        : DVD
Summary     : A library implementing the SSH2 protocol
URL         : http://www.libssh2.org/
License     : BSD
Description : libssh2 is a library implementing the SSH2 protocol as defined by
            : Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
            : SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
            : SECSH-DHGEX(04), and SECSH-NUMBERS(10).

Could you help me on this?

  • Edit your question and add the output of yum info libssh2 – A.B. Nov 29 '15 at 13:16
  • You should have used yum to install the package. Yum would have resolved all the dependencies for you. – fpmurphy Nov 29 '15 at 15:46
2

You try to install two packages. With the installation of libssh2-1.4.2-2.el6.x86_64.rpm you try to replace the file /usr/lib64/libssh2.so.1.0.1, which is also in the still installed package libssh2-1.4.2-1.el6_6.1.x86_64.

Use --upgrade to install a newer version:

rpm -ivh --upgrade libssh2-1.4.2-2.el6.x86_64.rpm libssh2-devel-1.4.2-2.el6.x86_64.rpm

and also possible

yum install libssh2-1.4.2-2.el6.x86_64.rpm libssh2-devel-1.4.2-2.el6.x86_64.rpm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.