3

I'm having trouble installing gcc on a new SLES 12 box. The goal here is actually to get R Shiny running, but when I try to install any packages I get the below error:

sudo su - -c "R -e \"install.packages('Rcpp',repos='https://cran.rstudio.com/')\""
make: g++: Command not found

This leads me to believe I need to install gcc.

which gcc:

which: no gcc in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/games)

gcc -version:

If 'gcc' is not a typo you can use command-not-found to lookup the package that contains it, like this: cnf gcc

This is where the trouble begins. When I zypper in gcc:

Problem: gcc-4.7-7.1.1.x86_64 requires gcc47, but this requirement cannot be provided uninstallable providers: gcc47-4.7.2_20130108-2.1.6.i586[oss] gcc47-4.7.2_20130108-2.1.6.x86_64[oss]

Ok.. zypper in gcc47-4.7.2_20130108-2.1.6.x86_64

Results:

Problem: gcc47-4.7.2_20130108-2.1.6.x86_64 requires glibc-devel, but this requirement cannot be provided uninstallable providers: glibc-devel-2.17-4.4.1.i586[oss] glibc-devel-2.17-4.4.1.x86_64[oss]

Right then... zypper in glibc-devel

Results:

Problem: glibc-devel-2.17-4.4.1.x86_64 requires glibc = 2.17, but this requirement cannot be provided uninstallable providers: glibc-2.17-4.4.1.i586[oss] glibc-2.17-4.4.1.x86_64[oss]

zypper in glibc

Results: `'glibc' is already installed.

No update candidate for 'glibc-2.19-17.72.x86_64'. The highest available version is already installed.

So somewhere in this chain of dependencies an RPM needs a lower version of something I already have. I don't want to downgrade the system. Is there some way to get the most up to date GCC that will work with glibc-2.19? Am I doing something wrong here? Am I missing a repo?

SLSE12:~ # cat /etc/os-release
NAME="SLES"
VERSION="12"
VERSION_ID="12"
PRETTY_NAME="SUSE Linux Enterprise Server 12"
ID="sles"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:suse:sles:12"


# zypper lr -u
# | Alias     | Name      | Enabled | Refresh | URI
--+-----------+-----------+---------+---------+-------------------------------------------------------------------------------
1 | gcc       | gcc       | Yes     | No      | http://download.opensuse.org/repositories/devel:/gcc/SLE-12/
2 | oss       | oss       | Yes     | No      | http://download.opensuse.org/distribution/12.3/repo/oss/
3 | r-patched | r-patched | Yes     | No      | http://download.opensuse.org/repositories/devel:/languages:/R:/patched/SLE_12/
  • If repo " download.opensuse.org/repositories/devel:/gcc/SLE-12 " : There is no gcc47 any more. About "glibc-devel" : System files can be installed only when you have paid / activated your SLES account / license. I.e. SLES12 is a commercial OS. ... – Knud Larsen Nov 28 '15 at 16:27
  • There is however a gcc48, and R Shiny is likely agnostic to which version to use, so why would I not be able to use that? – RedRaven Nov 28 '15 at 16:51
  • Just try : # zypper in gcc48-c++ ... or / and # zypper in gcc-c++ – Knud Larsen Nov 28 '15 at 21:07
  • same error, just different package gcc48-c++-4.8.5-161.1.x86_64 requires libstdc++48-devel = 4.8.5-161.1, but this requirement cannot be provided uninstallable providers: libstdc++48-devel-.8.5-161.1.x86_64[devel_gcc] libstdc++48-devel-4.8.5-161.1.x86_64[gcc] – RedRaven Nov 28 '15 at 21:59
0

We had the similar problem (needed to install igraph and tidygraph).
After registering the SLES 12 SP3 SDK the repo, which can be downloaded from this link, we installed:
* gcc-c++
* gcc-fortran
From there on we managed to install all the problematic packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.