2

How can i fix screen brightness i read a lot of document like install xbacklight it work only on terminalt but screen still the same i read also edit grub and append "acpi_backlight=vendor" or "video.use_native_backlight=1" to GRUB_CMDLINE_LINUX_DEFAULT still without any changing.

i tried also some solution like :

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

and append

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"
EndSection

from this Source still the same problem

4
  • Mint is close to Ubuntu, so might this answer help? askubuntu.com/questions/468277/…
    – SPRBRN
    Nov 28 '15 at 17:37
  • @SPRBRN i try this solution before no thing happen Nov 30 '15 at 10:58
  • When you've tried stuff like that, it's very helpful if you tell us about it. That saves us time, shows us that you tried different things, makes the question better, gets more upvotes etc.
    – SPRBRN
    Nov 30 '15 at 11:25
  • 1
    @SPRBRN Thanks and sorry for your time i will edit question now Nov 30 '15 at 11:48
1

To control brightness in do the following

  1. Open the terminal and type: leafpad /etc/default/grub

  2. find this line in the editor window: GRUB_CMDLINE_LINUX_DEFAULT="quiet" and change it to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

  3. Now type: update-grub

and restart the laptop


even after this the brightness is not working run the following commands(only for intel)

  1. ls /sys/class/backlight/ you might get the output like: ideapad intel_backlight (in place of ideapad you might get other things {depending on hardware})

  2. sudo -i gedit /usr/share/X11/xorg.conf.d/20-intel.conf run the above command and paste the below line

    Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "ideapad" "intel_backlight"
    BusID       "PCI:0:2:0"
    EndSection
    

    in the Option where is ideapad you have to paste what you had got in ls /sys/class/baclight/ command

    for eg: if it was acpi0 then Option "acpi0" "intel_backlight"

    1. reboot

    worked in linux mint 18 kernel 4.4.0-45-generic

0

If I get you correctly: changing screen brightness does not work. If so, I had the same problem and did the following for my (MINT 17.1) machine: I started using a script to directly change the brightness - not exactly elegant, but it does the trick:

  • search for you brighness control file: /sys/class/backlight/acpi_video0/brightness

  • manually change it as root via echo $value > brightness, with the value being the desired brightness, e.g. 20.

  • use a script do the same in future while unlocking the script in your sudoers.d directory

As script would look like

#!/bin/bash
read -p "enter desired brightness value:  " brightness

   #check if value is a positive integer
if [ "$( tr -d [[:digit:]] <<< $brightness )" == "" ] &&\
   #check value versus maximum value defined from the system side
   [ $brightness -lt $(cat /sys/class/backlight/acpi_video0/max_brightness) ]
then
  echo $brightness > /sys/class/backlight/acpi_video0/brightness
else
  echo "invalid brighntess value"
fi

Note: a value of 0 does not stand for a black screed (AFAIK), and on my system I actually got errors when trying to put invalid brightness values into the brightness file, so the if seem to be optional.

4
  • no error message but still the same Nov 30 '15 at 13:04
  • value of text file changed but no thing happen Nov 30 '15 at 13:07
  • did you try the file exactly as specified in my answer or did you try other entries from the /sys/class/backlight/group, too? It might be a different one on your system.
    – FelixJN
    Nov 30 '15 at 13:08
  • there is no folder such acpi_video0 i have intel_backlight on linux mint 17.2 Nov 30 '15 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.