1

today I'm looking for some serious help with getting my TP-Link TL-WN722N to work on my Kali Linux 2.0 VM. Just for some background, I'm running Kali Linux 2 within my Mac OS (Yosemite) using VirtualBox. The steps I took are as follows:

  • installed the image with 20GB of Storage and 2GB of RAM
  • updated and installed linux headers via apt-get update && apt-get install -y linux-headers-$(uname -r)
  • installed the Virtualbox Guest additions
  • rebooted Kali Linux
  • connected the usb device
  • ran airmon-ng and iwconfig

This, however, is where I run into issues. Running either of these commands will essentially freeze the terminal until I manually disconnect the device from its usb port. When I check dmesg to see what's going on after unplugging the device, it shows some errors, specifically saying that various processes have been blocked as shown in the image below.

dmseg

Now I'm not entirely sure what kworker or vminfo are, however their being blocked seems to be what's causing this "freeze" or possible deadlock situation?

After some research, I believe the issue to be with the firmware-atheros package. I tried removing the package and installing the jessie backports version of the firmware-atheros package, however after doing this the device would not connect at all.

I can provide any additional images, syslogs, etc., I just really would appreciate the help here as I'd like to learn more about network security and pen testing, and Kali seems to be a prime option for me. Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.