I'm running mobxterm as my windows ssh client, I have enable

"use external pageant & forward ssh agents" but I still cannot get it to work. I know authorized_keys are set correctly as its working on the other servers

Note i first need to access a jumpbox to jump to the needed server Pageant work fine on over 10 different servers, with the exeption of one.

Below is the log for the server that is not taking the authentication


ssh -vvv serverip
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug3: start over, passed a different list publickey,password,keyboard-interactive
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering public key: rsa-key-20140313
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Trying private key: /home/users/mj138q/.ssh/identity
debug3: no such identity: /home/users/mj138q/.ssh/identity
debug1: Trying private key: /home/users/mj138q/.ssh/id_rsa
debug3: no such identity: /home/users/mj138q/.ssh/id_rsa
debug1: Trying private key: /home/users/mj138q/.ssh/id_dsa
debug3: no such identity: /home/users/mj138q/.ssh/id_dsa
debug2: we did not send a packet, disable method
debug3: authmethod_lookup keyboard-interactive
debug3: remaining preferred: password
debug3: authmethod_is_enabled keyboard-interactive
debug1: Next authentication method: keyboard-interactive
debug2: userauth_kbdint
debug2: we sent a keyboard-interactive packet, wait for reply
debug2: input_userauth_info_req
debug2: input_userauth_info_req: num_prompts 1
Password:

this is a working one


debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug3: start over, passed a different list publickey,password,keyboard-interactive
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering public key: rsa-key-20140313
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Server accepts key: pkalg ssh-rsa blen 148
debug2: input_userauth_pk_ok: fp aa:dd:5e:11:ff:92:f3:2d:21:fc:c2:6a:e2:d1:d5:a1
debug3: sign_and_send_pubkey
debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug2: callback start
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 1
debug2: channel 0: request shell confirm 1
debug2: fd 3 setting TCP_NODELAY
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel_input_status_confirm: type 99 id 0
debug2: PTY allocation request accepted on channel 0
debug2: channel 0: rcvd adjust 2097152
debug2: channel_input_status_confirm: type 99 id 0
debug2: shell request accepted on channel 0 Last login: Wed Nov 25 23:17:27 2015 Sun Microsystems Inc. SunOS 5.10 Generic January 2005 You have mail.

  • Post the ssh -vvv debug output from one of the servers where this does work so we/you can compare the 2 outputs. – rubynorails Nov 26 '15 at 3:28
  • FYI the Jump server is always the same example. miguel@jumpserver.com the first debug is from the server that is not accepting the authentication.key the second output is a server that is taking the authentication key. – Jimenez Miguel Nov 26 '15 at 5:25
  • Are you certain that public key authentication is enabled in the sshd_config on the server that is giving you problems? – rubynorails Nov 26 '15 at 5:55
  • yes I am 100 % sure – Jimenez Miguel Nov 27 '15 at 18:22
  • Are there any obvious differences between the problem server and the others -- such as operating system, OS version, etc? Do a diff or Beyond Compare comparison of the sshd_config of the problem server and the sshd_config of a server where this is working as expected. That should shed some light on the situation. Also, kind of important -- what OS is the problem server running? – rubynorails Nov 28 '15 at 1:03
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,password,keyboard-interactive 

This means your SSH client sent a public key, but it was rejected by the server. Contact the server administrator and have them check the server-side authentication log (in Linux, usually /var/log/secure or /var/log/auth.log depending on distribution): the server-side log should have a very clear message from sshd describing why the public key was rejected.

The rejection reason is not sent to an as-yet unidentified client, for security reasons. You wouldn't give a stranger fiddling with the lock of the front door of your home any advice on the type of lockpick to use, would you?

The most common reason for problems like this is wrong file permissions on the authorized_keys file, the .ssh sub-directory or the user's home directory on the server. None of those should be writable by anyone other than the owner of the account. The error message in the server log will include an exact pathname of the file or directory that causes the key to be rejected as not secure.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.