3

My Cloud9 (Ubuntu-based cloud IDE) began to be unresponsive after I tried to save some files (they didn't save to my cloud workspace). It shows 100% CPU utilization and a process that takes all CPU power.

Here is the error from which the 100% CPU utilizing vfs-worker process starts:

Failed to write to 'settings.py'. Failed saving file ! : djangoserver/djangoserver/settings.py ERR: Error: EACCES, open '/home/ubuntu/workspace/djangoserver/djangoserver/settings.py'.

Rights in djangoserver directory with djangoserver/settings.py:

-rw-r--r-- 1 root root    0 Nov 25 15:21 __init__.py
-rw-r--r-- 1 root root  147 Nov 25 15:33 __init__.pyc
-rw-r--r-- 1 root root 1990 Nov 25 15:21 settings.py
-rw-r--r-- 1 root root 2174 Nov 25 15:33 settings.pyc
-rw-r--r-- 1 root root  303 Nov 25 15:21 urls.py
-rw-r--r-- 1 root root  399 Nov 25 15:21 wsgi.py

Rights in the parent directory:

enter image description here

The process causing this is:

vfs-worker {"pi

and it seems to be associated with the IDE (after killing it it displays Reconnecting... message). After killing it the process restarts itself with a different PID.

This might as well be a bug in the IDE based on the misspelled name. I tried restarting the whole IDE, but it comes back right after restart.

Before I dismiss this as a bug I would like to see if there could be other causes to this. I also have Python module virtualenv installed (not sure what it does) as a requirement for adding MongoDB support to Django. This might also be caused by virtualenv, which I added just recently according to this tutorial.

0

I noticed the error was affecting only djangoserver directory in my workspace, the steps I took were:

  1. Delete djangoserver. Even after deletion of the djangoserver folder I could see the IDE displaying a different error and still crashing on 100% CPU load:

Failed to delete folder ‘testenv'. stderr maxBuffer exceeded..

  1. Restart workspace. By doing this the whole problem was solved.

Not sure what it was, it may be a bug in the IDE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.