I'm running Arch Linux 4.2.5-1 with xfce4 on an Asus x205ta and for some reason, sudo systemctl suspend seems to just freeze my system. I know it is suspending because when I check journalctl it shows it with:

Nov 25 13:26:32 arch systemd-sleep[474]: Suspending system...

However, my laptop simply won't resume and I don't know why. I can mash the power button and any key on my laptop all day long but it refuses to resume. I have to hold down the power button to "turn it off" because it won't come out of the suspended state.

One thing to note is if I run sudo systemctl suspend within the tty terminal (outside of x), the screen simply freezes in place and the power LED remains on. I can't type anything, the cursor doesn't blink, and I have to reboot for anything to work again. However, if I run it within xfce4, the screen turns off as if it is actually going to sleep and the power LED also turns off.

When I run pm-suspend, nothing seems to happen. When I check journalctl, it says:

Nov 25 13:31:52 arch sudo[592]: pam_unix(sudo:session): session opened for user root by hayden(uid=0)

Nov 25 13:31:52 arch sudo[592]: pam_unix(sudo:session): session closed for user root

  • are you running grub? and if so, does the file /etc/default/grub contain a line something like: GRUB_CMDLINE_LINUX="resume=/dev/sdYZ" (where YZ is the swap partition location)? if not, you need to add such and to save those changes with the appropriate update-grub command. – Theophrastus Nov 27 '15 at 19:32

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.