0

Some months ago I ran an helloworld MirageOS app on Xen on my machine without any problem, now I wanted to get back into using Xen, but I have some issues.

Plenty of things changed: The previous machine (for which I don't have access anymore) on which I run it was a Dell laptop with both integrated (intel) and discrete (amd) gpus, while now I'm running on a Thinkpad with only intel. I was running Ubuntu 15.04, while now I'm running 15.10 (shouldn't change much, but maybe the different kernel version is at fault). Now I'm also running Btrfs for my / filesystem (mainly for the checksumming).

So, after booting dom0, on my natively installed Linux (Ubuntu), everything seems fine, but after a split second, the mouse pointer disappears from both lightdm and my unity/gnome session after login.

Also, I see that the cpu usage from my activity-monitor widget is apparently almost to 100%, but while looking to top, I only see things like Xorg using ~16%.

Thinking that memory might have been an issue, I try to create a zero-ed 2GB file to be used as swap (I know: I cannot use a swapfile that simply with btrfs), and I realized that it's incredibly slow: 20MB/s to write it to disk. After rebooting into my normal kernel, I try to create the same kind of file, and I get a bandwidth around 300MB/s (as expected with my SSD).

The whole gui, on the xen kernel, seems sluggish... alt-tabbing and switching desktops has noticeable delays.... I was thinking that maybe the intel graphic drivers would be the issue, but the disk slowness, and increased apparent cpu usage, lead me to think that it might not be that simple.

I tried to do a few things: install/uninstall Virtualbox (so as not to load vboxdrv), enable/disable VT-x in the EFI... but I don't see any improvement.

This is the dmesg output when running with the Xen kernel. The only 2 things that seem really off to me are:

ACPI Exception: AE_BAD_PARAMETER, Thread 79174528 could not acquire Mutex [0x1] (20150619/utmutex-285)

and

vgaarb: this pci device is not a vga device

For the former, I tried to set acpi=off in the boot options (but Xen it's not using the usual linux command, but a multiboot one... so I might have put the option in the wrong place)

In both cases I tried to google for possible known causes of this problem, and apparently other people had similar issues, but none of the resuls seem to lead to anything. Same thing for the xen wiki.

What would the next step be? How to pin down the exact issue?

Thank you

0

After having another look at the dmesg output, this line caught my attention:

pci 0000:00:14.0: can't find IRQ for PCI INT A; please try using pci=biosirq

(together with a lot of others IRQ errors)

By googling it, I found this thread

Apparently, it turns out that booting with the Grub multiboot on an EFI system is not well supported

I opened this issue for the ubuntu package, and I'll now resort to test xen on another (virtual?) machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.