3

Trying to automate making a ppp connection on boot. I have a cell modem (skywire LE910 SVG) that I have working manually using pon. My ppp/peers/isp is configured and the corresponding chatscript is working. After my device boots (beaglebone black running 3.8.13 Debian wheezy) I can run pon verizon (name of isp) and then see my established ppp0 via ifconfig.

How do I make this happen on boot?

  • More perplexing is that fact that pon verizon or pppd call verizon works fine yet if put this command in a simple bash script #!/bin/bash pppd call verizon try to establish connection disconnects at the end of execution and ppp0 is never listed as a connection when I ifconfig – matt99eo Dec 2 '15 at 21:33
2

Edit the /etc/network/interfaces file, and add:

auto tunnel
iface tunnel inet ppp
        provider verizon

Helpful read: http://pptpclient.sourceforge.net/howto-debian.phtml

  • This is not a VPN but a persistent connection. Isn't pptp for vpn? – matt99eo Dec 2 '15 at 16:31
  • 1
    If you're unsure if ppp is what you actually want, then why did you write Trying to automate making a ppp connection on boot? – Jan Dec 4 '15 at 9:42
1

Found an issue with the ppp/peers/provider file

Removing updetach from the provider file fixed it.

updetach With this option, pppd will detach from its controlling terminal once it has successfully established the ppp connection (to the point where the first network control protocol, usually the IP control protocol, has come up).

Can anyone explain why this fixed my problem :)? Solved it but not 100% sure why this worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.