0

I'm trying to install virtual box using the method on wiki.debian.org and I'm encountering problems. When I execute

# apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') virtualbox

I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  binutils cpp-4.8 dkms fakeroot gcc gcc-4.8 gcc-4.9 libasan0 libasan1
  libatomic1 libc-dev-bin libc6-dev libcilkrts5 libcurl3 libfakeroot
  libgcc-4.8-dev libgcc-4.9-dev libgsoap5 libitm1 liblsan0 libqt4-network
  libqt4-opengl libtsan0 libubsan0 libvncserver0 linux-compiler-    gcc-4.8-x86
  linux-headers-3.16.0-4-amd64 linux-headers-3.16.0-4-common linux-    kbuild-3.16
  linux-libc-dev make manpages-dev menu virtualbox-dkms virtualbox-qt
Suggested packages:
  binutils-doc gcc-4.8-locales gcc-multilib autoconf automake libtool flex
  bison gdb gcc-doc gcc-4.8-multilib gcc-4.8-doc libgcc1-dbg libgomp1-dbg
  libitm1-dbg libatomic1-dbg libasan0-dbg libtsan0-dbg libquadmath0-dbg
  gcc-4.9-multilib gcc-4.9-doc gcc-4.9-locales libasan1-dbg liblsan0-dbg
  libubsan0-dbg libcilkrts5-dbg glibc-doc make-doc menu-l10n gksu kde-runtime
  ktsuss vde2 virtualbox-guest-additions-iso
Recommended packages:
  linux-image
The following NEW packages will be installed:
  binutils cpp-4.8 dkms fakeroot gcc gcc-4.8 gcc-4.9 libasan0 libasan1
  libatomic1 libc-dev-bin libc6-dev libcilkrts5 libcurl3 libfakeroot
  libgcc-4.8-dev libgcc-4.9-dev libgsoap5 libitm1 liblsan0 libqt4-network
  libqt4-opengl libtsan0 libubsan0 libvncserver0 linux-compiler-gcc-4.8-x86
  linux-headers-3.16.0-4-amd64 linux-headers-3.16.0-4-common
  linux-headers-amd64 linux-kbuild-3.16 linux-libc-dev make manpages-dev menu
  virtualbox virtualbox-dkms virtualbox-qt
0 upgraded, 37 newly installed, 0 to remove and 0 not upgraded.
Need to get 22.7 MB/56.9 MB of archives.
After this operation, 227 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
WARNING: The following packages cannot be authenticated!
  libasan1 libcilkrts5 libcurl3 libgsoap5 liblsan0 libqt4-network
  libqt4-opengl libubsan0 libvncserver0 virtualbox libgcc-4.9-dev gcc-4.9 gcc
  make dkms virtualbox-dkms virtualbox-qt libfakeroot fakeroot linux-libc-dev
  linux-compiler-gcc-4.8-x86 linux-headers-3.16.0-4-common
  linux-headers-3.16.0-4-amd64 manpages-dev menu
Install these packages without verification? [y/N] Y
Get:1 http://security.debian.org/ jessie/updates/main libcurl3 amd64     7.38.0-4+deb8u2 [259 kB]
Media change: please insert the disc     labeled                                   
 'Debian GNU/Linux 8.2.0 _Jessie_ - Official amd64 xfce-CD Binary-1     20150906-11:10'
in the drive '/media/cdrom/' and press enter

Get:2 http://http.debian.net/debian/ jessie/contrib virtualbox amd64     4.3.18-dfsg-3+deb8u3 [15.9 MB]
Get:3 http://http.debian.net/debian/ jessie/main libqt4-opengl amd64 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 [343 kB]
Get:4 http://http.debian.net/debian/ jessie/main libqt4-network amd64 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 [605 kB]
Get:5 http://http.debian.net/debian/ jessie/main libgsoap5 amd64 2.8.17-1 [202 kB]
Media change: please insert the disc     labeled                                   
 'Debian GNU/Linux 8.2.0 _Jessie_ - Official amd64 xfce-CD Binary-1     20150906-11:10'
in the drive '/media/cdrom/' and press enter

Get:6 http://http.debian.net/debian/ jessie/main libvncserver0 amd64     0.9.9+dfsg2-6.1+deb8u1 [191 kB]
Get:7 http://http.debian.net/debian/ jessie/contrib virtualbox-qt amd64     4.3.18-dfsg-3+deb8u3 [4,656 kB]
Media change: please insert the disc     labeled                                   
 'Debian GNU/Linux 8.2.0 _Jessie_ - Official amd64 xfce-CD Binary-1     20150906-11:10'
in the drive '/media/cdrom/' and press enter

Media change: please insert the disc     labeled                                 
 'Debian GNU/Linux 8.2.0 _Jessie_ - Official amd64 xfce-CD Binary-1     20150906-11:10'
in the drive '/media/cdrom/' and press enter

which I just don't understand. I assumed that I was being told to put the disc that installed Debian from in the drive, which I did, pressed enter numerous times, and not much happened.

I note that I am able to install virtualbox and run it and import appliances. I then get an error when I try to use the appliance which is presumably because I have been unable to install the dkms correctly which virtualbox requires to correctly handle kernels. I'm not able to find a file to download and burn to a disc that is called "Debian GNU/Linux 8.2.0 Jessie - Official amd64 xfce-CD Binary-1 20150906-11:10".

What am I missing? I'm sure it's something very simple but it has been eluding me for days now.

2

Yes, it's asking for the disc you installed Debian from (well, or another copy of the same disc). For some reason, it's not finding it...

Since it appears you have network access, the easiest fix is probably to just remove/comment out the disc from /etc/apt/sources.list then run apt-get update. Then your apt-get install should succeed.

PS: You really ought not be getting (or ignoring!) those packages cannot be authenticated errors. Make sure apt-get update runs without any errors.

0

Open and modify the file /etc/apt/sources.list vi /etc/apt/sources.list

Comment by using # before (both the lines)

"Debian GNU/Linux 8.2.0 Jessie - Official amd64 xfce-CD Binary-1 20150906-11:10"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.