RedHat/CentOS 7.1.1503; GNOME Shell 3.8.4

I name my workspaces after current projects I'm working on (for 1-4 weeks). How can I rename them from "1" "2"... to something like "Vienna" "Berlin"?

In CentOS6 I just right clicked on the workspace panel add-on and renamed them in the properties.

I already found the "Workspace Lables" extension ( https://extensions.gnome.org/extension/551/workspace-labels/ ) but this does not allow me to change the names.

4 Answers 4


OK, found a way via gsettings:

$ gsettings set org.gnome.desktop.wm.preferences workspace-names "['Com', 'Vienna', 'Test1', 'Test2','Test3']"
$ gsettings set org.gnome.desktop.wm.preferences num-workspaces "5"

I would like to add one thing to the Nico's answer.

When you run this command, if you get the GLib-GIO-Message:

 GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

check the path to the command. In my case running which gsettings showed path to the anacoda folder:


Using absolute path to the system gsettings solved the problem:

 /usr/bin/gsettings set ...

PS. This answer is based on one answer here


Workspace Indicator is a part of the core extensions and allows naming workspaces.

Once installed, go into the extension settings and then double click on the workspace you want to rename.

  • 2
    The question asks how to do it... perhaps you could elaborate with instructions?
    – theMayer
    Commented Sep 24, 2018 at 15:06

use apps->utilities->tweak->extensions->workspace indicator->settings(gear icon) to rename

Of course you have to install the extensions first....

BTW if anyone known how to make a shortcut for this, I'd appreciate it. One of the things I really miss from Centos 6 is the ability to right-click on the workspace name and rename it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .