1

I have a very annoying problem on my computer that I'm unable to solve.

I had the same issue in two distributions, first in Ubuntu and now in Fedora.

My computer used to work fine with Ubuntu, but after some kernel update the sound stopped working. I moved to Fedora 21 because I couldn't find a solution and, surprise, I had the same issues.

So I guess it's something related to some hardware/kernel incompatibility.

The problem is that the sound of my system mutes minutes after using voice IP (Skype for instance) or watching videos via my browser (Firefox or Chrome).

If I reboot, I have sound again. But as soon as I start, for instance, a Skype conversation, the sound stops working. I start the teleconf but several minutes after I have no sound. However, the microphone continues working.

A secondary effect of this problem is that once the sound is muted (because watching videos or using voice IP protocols), the browser videos (from YouTube for instance) are not showing well. They are shown in slow-motion with interruptions of milliseconds.

I have my fedora 21 updated and my video card is NVIDIA GeForce 9500 GT (using free drivers).

I tried multiple things (pulseaudio -k, alsamixer, etc.) but none worked. I would really appreciate any help. Please let me know if you need some extra information?

EXTRA INFO:

My audio devices are listed here:

$ /sbin/lsmod | grep snd

snd_hda_codec_realtek    90112  0 
snd_hda_codec_generic    73728  2 snd_hda_codec_realtek
snd_hda_intel          32768  4 
snd_hda_controller     32768  1 snd_hda_intel
snd_hda_codec         110592  4         snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hda_core           36864  4     snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_codec,snd_hda_controller
snd_hwdep              16384  1 snd_hda_codec
snd_seq                69632  0 
snd_seq_device         16384  1 snd_seq
snd_pcm               118784  3     snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer              32768  2 snd_pcm,snd_seq
snd                    81920  17             snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              16384  1 snd

$ lspci | grep Audio

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)

Hardware devices:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: ID 889 Analog [ID 889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 1: ID 889 Digital [ID 889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I have also tried using alternative desktops (I'm using gnome3) like xfce or cinnamon but it didn't work. It happened the same.

Typing pulseaudio with or without sound gives me:

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

Same more info:

$ modinfo snd-hda-intel

filename:       /lib/modules/4.1.13-100.fc21.x86_64/kernel/sound/pci/hda/snd-hda-intel.ko.xz
description:    Intel HDA driver
license:        GPL
depends:        snd-hda-controller,snd-hda-codec,snd-pcm,snd
intree:         Y
vermagic:       4.1.13-100.fc21.x86_64 SMP mod_unload 
signer:         Fedora kernel signing key
sig_key:        F3:54:63:EF:F6:27:ED:52:16:79:72:BC:8F:3C:71:2E:D1:C9:E4:F0
sig_hashalgo:   sha256
parm:           index:Index value for Intel HD audio interface. (array of int)
parm:           id:ID string for Intel HD audio interface. (array of charp)
parm:           enable:Enable Intel HD audio interface. (array of bool)
parm:           model:Use the given board model. (array of charp)
parm:           position_fix:DMA pointer read method.(-1 = system    default, 0 = auto, 1 = LPIB, 2 = POSBUF, 3 = VIACOMBO, 4 = COMBO). (array of int)
parm:           bdl_pos_adj:BDL position adjustment offset. (array of int)
parm:           probe_mask:Bitmask to probe codecs (default = -1). (array of int)
parm:           probe_only:Only probing and no codec initialization. (array of int)
parm:           jackpoll_ms:Ms between polling for jack events (default = 0, using unsol events only) (array of int)
parm:           single_cmd:Use single command to communicate with codecs (for debugging only). (bool)
parm:           enable_msi:Enable Message Signaled Interrupt (MSI) (bint)
parm:           patch:Patch file for Intel HD audio interface. (array of charp)
parm:           beep_mode:Select HDA Beep registration mode (0=off, 1=on) (default=1). (array of bool)
parm:           power_save:Automatic power-saving timeout (in second, 0 = disable). (xint)
parm:           power_save_controller:Reset controller in power save mode. (bool)
parm:           align_buffer_size:Force buffer and period sizes to be multiple of 128 bytes. (bint)
parm:           snoop:Enable/disable snooping (bint)

If I run alsamixer the default card is Pulseaudio and chip Pulseaudio. If I change the card with F6 and select HDA Intel MID then the chip is Realtek ID 889. There is nothing mute even when the system sound does not work.

  • If you're able to find the name of your audio device (perhaps some of the programs you tried will complain about being unable tu use it), then the fuser command may help you find if a specific program is hogging it. – dhag Nov 24 '15 at 16:28
  • Try to do kind of debugging. In linux, you can play sound via completely different interfaces. Other thing is that better to ask questions about things which seems to be bug in distribution specific forums/mailing lists or if you have relatively able identify subsystem responsible for the problem (alsa or pulseaudio) - directly on subsystems mailing list. If you want to understand, there is alsa (partly in kernel, partly as software library) which actually implement audio processing and pulseaudio which does kind of mixing of application streams. Try to figure out which one is failed. – gena2x Nov 24 '15 at 16:32
  • You can test alsa using any wav file and aplay tool. Really carefully check alsamixer controls. Use amix to dump state of mixer before and after failure. Use diff or meld to see changes. Check kernel logs (dmesg) for any errors. – gena2x Nov 24 '15 at 16:35
  • Thanks for your comments. I have updated the post with all the information I thought could be interesting. When the sound fails rebooting alsa or pulseaudio don't work. Alsamixer seems OK even when the sound mutes. Only rebooting works. I would really appreciate if you could give me a to-do-list for dummies since I'm not a expert linux user and I'm absolutely frustrated. – cardogar Nov 25 '15 at 9:49
  • BTW I also tried reinstalling alsa (it seemed to help in some other posts) but after rebooting the sound failed again. Ah, this file /etc/modprobe.d/alsa-base.conf does not exist in my computer... but it seems it's not necessary because the sound, unless I start a voIP teleconf, works. – cardogar Nov 25 '15 at 10:06
0

There are a few areas where you could try. I use Debian, but the general ideas should work for your system, too.

  • Have you tried a utility called pavucontrol? It may give you a better idea of your Pulse setup.
  • By default the Pulse server will respawn, so the server's instance killed by pulseaudio -k will be replaced with another one. To check whether your issue gets better after stopping Pulse for real, modify /etc/pulse/client.conf or ~/.config/pulse/client.conf
    from
    autospawn = yes
    to
    autospawn = no
    and then stop Pulse.
  • You may want to follow the steps described in https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Audio_quality, particularly in the section on snd_hda_intel module workarounds.
  • Lastly, I would suggest something less intuitive: update your drivers with non-free versions, including your video driver. Nvidia releases Linux drivers available for download from their website, but you should be able to get them through your distribution. On Debian I always append contrib non-free to my /etc/apt/sources.list line, so that non-free software (like firmware and Nvidia drivers) gets updated regularly. In my case a relevant line is:
    deb http://pubmirrors.dal.corespace.com/debian/ testing main contrib non-free
  • 1
    Thanks for your detailed instructions. I have pavucontrol and everything seems to be alright even with the system sound muted. I also knew the link and I checked it some time ago, I will do it again since I have now more experience. I think the problem is related to alsa because I follow this instructions fedoraproject.org/wiki/How_to_debug_sound_problems to discard the pulseaudio problems and I still had them. I also considered updating the drivers but I've read that it can be tricky. – cardogar Nov 26 '15 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.