0

In the Mate desktop it is easy to launch applications with the menu search (menu pops up with the default Super_L key). But it remembers the initial search in such a way that when I try to launch a new application, just using the short-key and then typing the new search (like in other launchers - Synapse, Unity Dash, Whisker Menu, KDE menu search, etc) this doesn't lead to the expected result: the old search is not replaced by the new one, but the new one is added to the old.

e.g., if I first search for "vlc" and the program is started, and then I want to launch Firefox in the same way, writing "firefox" would result in searching "vlcfirefox".

enter image description here

Should the first search be selected when the menu pops up for the second search, remembering the initial search would not be a problem: then, typing a new search would replace the old.

enter image description here

This problem is not too severe: the new search can be entered correctly if backspace key is pressed (long press :)) or if Ctrl+A is used to select the old search so it is replaced by the new.

But this is cumbersome compared to other search solutions out there where you don't have to look but instead can just start typing when the menu is visible.

Can this be changed?

0

yes it can! ;-)

right-click on the MATE/Mint-menu and open the Preferences: go to the Applications-tab and uncheck Remember the last category or search (it should be the last item).
normally (on LinuxMint MATE) this is unchecked by default...!

This image shows the menu preferences window, where the application tab is selected.

  • great! I have to test this to confirm as now I don't use MATE, but I'll plug a live usb soon. – user32012 Jan 26 '16 at 11:09
  • do you also know how to make the menu start the application when I press enter instead of starting searching for a file with that name? (example: I press Supper button: menu opens. I write "fir": it shows Firefox, just like any launcher. I press Enter, it starts searching the whole system for files named "fir".) I can avoid this by pressing down-arrow before Enter but I find this behavior odd and want to change it. – user32012 Jan 26 '16 at 15:45
  • unix.stackexchange.com/q/257783/32012 – user32012 Jan 26 '16 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy