10

I have an Acer Aspire on which I installed Linux Mint 17.2. The touchpad does not work at all; xinput doesn't even list any touchpad unit at all. Probably a driver issue, is there some way to make it work?

2
  • 1
    even if you're providing the answer yourself, you should still phrase this as a question.
    – cas
    Commented Nov 23, 2015 at 10:55
  • 1
    For me it was enough to re-enable touchpad by typing <kbd>FN</kbd>+<kbd>F7</kbd>. I have Debian stretch LXDE...
    – bemik
    Commented Apr 28, 2019 at 10:52

6 Answers 6

10

The solution: add i8042.nopnp to the kernel command line. To do this:

sudoedit /etc/default/grub

and add:

GRUB_CMDLINE_LINUX="i8042.nopnp"

If there's already a line with GRUB_CMDLINE_LINUX=…, add i8042.nopnp inside the quotes, separated from any other word within the quotes by a space, e.g.

GRUB_CMDLINE_LINUX="some-other=option i8042.nopnp"

Then run

sudo update-grub

and reboot. Hope it works, it worked for me!

4
  • Had the same problem on Acer TravelMate B. This solved the problem for me.
    – Student
    Commented Dec 21, 2019 at 23:29
  • Also worked for Aspire One Cloudbook 14 and Ubuntu 20.04 with Kde
    – ATorras
    Commented Jan 7, 2022 at 18:40
  • Struggling with this with an Aspire 1 A115-32. Make sure the Touchpad is set to 12c in the BIOS, and then this worked like a charm. Commented Dec 30, 2022 at 1:50
  • Worked perfectly on a clean Lubuntu installation after updates, curious to know what i8042.nopnp do/has though...
    – Armfoot
    Commented Mar 4 at 11:59
5

For acer laptops, After installing drivers if it's still not working.

then you have To re-enable your touchpad: On your laptop keyboard, press the Fn key and the F6 or F7 key (the function key with a touchpad icon on it) at the same time. Then check to see if you're able to use your touchpad.

So try clicking or swiping after pressing the keys mentioned, to see it's enabled.

Source: https://www.drivereasy.com/knowledge/acer-laptop-touchpad-not-working-solved/

2
  • and then, will it work or not? Commented May 19, 2018 at 7:49
  • yes it will. try clicking or swiping after pressing the keys mentioned. to see its enabled. Commented May 20, 2018 at 17:14
2

Menu -> Administration -> Update Manager -> (Install Updates -- Ensure you Update the kernel) -> reboot -> Fn - F7

Inspired by : http://www.dedoimedo.com/computers/linux-mint-touchpad-fix.html

Linux Mint Serena - Aspire V3-575-5OTD (Updated to kernel v4.4.0-62)

1

Try F7. I had this same problem installing Mint on Acer Aspire 5. I tried as suggested Fn + F7 but it did not work. My F7 key has a picture of a touchpad on it, so it is used to enable/disable touchpad. It worked when I did not use Fn key, just F7.

1
  • You saved my night ! Thanks !
    – JCLL
    Commented May 11, 2020 at 22:22
0

After going through lots of bug reports and solutions, managed to boot kubuntu 19.10, kernel 5.3 with a working touchpad (elan). My device is

  • ACER Aspire 3 A315-41-R955
  • bios 1.13 version
  • AMD Ryzen 5 2500U cpu

Steps:

  1. disable secure boot in bios settings
  2. Add these two lines in /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="ivrs_ioapic[32]=00:14.0 nosplash irqpoll"
GRUB_CMDLINE_LINUX="psmouse.elantech_smbus=0"
  1. sudo update-grub

Thats all.

0
0

I've tried it all...

  • In my research there was talk of blacklisting I2C modules to force alternate modules to manage the synaptic touchpad. So my suspicions were confirmed when I found the i2c_i801 module blacklisted by default in LinuxMint - Serena. I un-blacklisted it, reboot and viola -- the return of the functional touchpad.
  • I also changed the touchpad mode to BASIC in the BIOS. Not the most elegant solution but it does work reliably. the touch pad can be disabled and re-enabled as needed via Fn-F7

I say not the most elegant as the USB receiver or attached mouse has to be disconnected at boot time and plugged in after the system is up if required.

Brief how to below. Note: Words in between /* .. */ are comments.

  • Open blacklist (in vi in this example)

    sudo vi  /etc/modprobe.d/blacklist.conf
    
  • In VI.. search for the i2c blacklisting by typing:

    \i2c
    
  • Then comment the line jumped to by preceeding with a hashtag

    I[press enter]#
    
  • You should have:

    #blacklist i2c_i801
    
  • Now save and exit by:

    [press 'Esc' key]:wq!
    
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .