2

I have an Acer Aspire on which I installed Linux Mint 17.2. The touchpad does not work at all; xinput doesn't even list any touchpad unit at all. Probably a driver issue, is there some way to make it work?

  • 1
    even if you're providing the answer yourself, you should still phrase this as a question. – cas Nov 23 '15 at 10:55
  • 1
    For me it was enough to re-enable touchpad by typing <kbd>FN</kbd>+<kbd>F7</kbd>. I have Debian stretch LXDE... – bemik Apr 28 at 10:52
2

The solution: add i8042.nopnp to the kernel command line. To do this:

sudoedit /etc/default/grub

and add:

GRUB_CMDLINE_LINUX="i8042.nopnp"

If there's already a line with GRUB_CMDLINE_LINUX=…, add i8042.nopnp inside the quotes, separated from any other word within the quotes by a space, e.g.

GRUB_CMDLINE_LINUX="some-other=option i8042.nopnp"

Then run

sudo update-grub

and reboot. Hope it works, it worked for me!

2

Menu -> Administration -> Update Manager -> (Install Updates -- Ensure you Update the kernel) -> reboot -> Fn - F7

Inspired by : http://www.dedoimedo.com/computers/linux-mint-touchpad-fix.html

Linux Mint Serena - Aspire V3-575-5OTD (Updated to kernel v4.4.0-62)

1

For acer laptops, After installing drivers if it's still not working.

then you have To re-enable your touchpad: On your laptop keyboard, press the Fn key and the F6 or F7 key (the function key with a touchpad icon on it) at the same time. Then check to see if you're able to use your touchpad.

So try clicking or swiping after pressing the keys mentioned, to see it's enabled.

Source: https://www.drivereasy.com/knowledge/acer-laptop-touchpad-not-working-solved/

  • and then, will it work or not? – Pierre.Vriens May 19 '18 at 7:49
  • yes it will. try clicking or swiping after pressing the keys mentioned. to see its enabled. – Manoj Selvin May 20 '18 at 17:14
0

I've tried it ALL...in my research there was talk of blacklisting i2c modules to force alternate modules to manage the synaptic touchpad.. So my suspicions were confirmed when I found the i2c_i801 module blacklisted by default in LinuxMint - Serena. I un-blacklisted it, reboot and viola -- the return of the functional touchpad. I also changed the touchpad mode to BASIC in the BIOS. Not the most elegant solution but it does work reliably. the touch pad can be disabled and re-enabled as needed via Fn-F7... I say not the most elegant as the USB receiver.. or attached mouse has to be disconnected at boot time... and plugged in after the system is up if required. Brief how to below. Note: Words in between /* .. */ are comments.

$ sudo vi /etc/modprobe.d/blacklist.conf

/* In VI.. search for the i2c blacklisting by typing: */

\i2c

/* Then comment the line jumped to by preceeding with a hashtag */

I[press enter]#

/* You should have: */

#blacklist i2c_i801

/* now save and exit by: */

Esc[press 'Esc' key]:wq!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.