3

I've got a rather odd issue. I recently installed debian 8 on a Toshiba Kirabook and have some issues with the wifi. When going to the gnome wifi selection it says no networks available so I can't choose to connect to anything.

However I got the wifi to work by adding the following to /etc/network/interfaces:

...
allow-hotplug wlan0
iface wlan0 inet dhcp
    wpa-ssid <myssid>
    wpa-psk <mypassword>

I'm unhappy that I can't select different networks via the standard gnome interface. However I'm also unhappy to have my passwords stored in plain text like that.

How could I go about debugging this problem so that I'll be able to select different networks based on availability and most importantly via the gnome setting?

Edit: solved

This question here disscussed a similar issue and the solution was to remove the SSID from the interfaces. Apparently the network manager does not manages devices that are covered in /etc/network/interface.

After removing it, all networks showed up correctly.

1

Do you have your wifi driver properly installed? If not please follow:

Add a "non-free" component to /etc/apt/sources.list for your Debian version:

# Debian 8 "Jessie"
deb http://http.debian.net/debian/ jessie main contrib non-free

Update the list of available packages and install the firmware-ipw2x00 and wireless-tools packages:

# apt-get update
# apt-get install firmware-ipw2x00 wireless-tools

For more information refer to: https://wiki.debian.org/ipw2200

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.