1

Running Arch Linux, kernel 4.2.5-1, Lightdm 1.16.5, xorg-server 1.17.4-2, nvidia 255.11-4, GTX 780 dual-link dvi out.

I have a QNIX Evolution II 2710 and am attempting to overclock it but am running into some issues with xorg. To summarize: if I glance at xorg's config the wrong way, I get a test screen. I already tried swapping output ports and Dual-DVI cables - no change. Below is the relevant portion of my xorg.conf. Lines are commented because I copy/pasted this from my current config and I prefer to have a working desktop :)


Section "Monitor"

#    HorizSync       88.8 - 88.8
#    VertRefresh     48.0 - 120.0
    Identifier     "Monitor0"
    VendorName     "Unknown"
#    ModelName      "HYO DUAL-DVI"
#    ModeLine       "2560x1440_60" 312.25 2560 2752 3024 3488 1440 1443 1448 1493 -hsync +vsync
#    ModeLine       "2560x1440_86" 330.00 2560 2608 2640 2652 1440 1441 1444 1445 +hsync +vsync
#    ModeLine       "2560x1440_96" 519.25 2560 2776 3056 3552 1440 1443 1448 1524 -hsync +vsync
#    ModeLine       "2560x1440_96_2" 400.00 2560 2608 2640 2744  1440 1443 1448 1512 +hsync +vsync
#    ModeLine       "2560x1440_99" 536.50 2560 2776 3056 3552 1440 1443 1448 1527 -hsync +vsync
#    ModeLine       "2560x1440_120" 661.25 2560 2784 3064 3568 1440 1443 1448 1545 -hsync +vsync
#    Modeline       "2560x1440_120_2" 459.86 2560 2608 2640 2652  1440 1441 1444 1445 +hsync +vsync
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 780"
    Option         "NoLogo" "True"
    Option         "ConnectedMonitor" "DFP-3"
#    Option         "CustomEDID" "DFP-3: /etc/X11/2710_edid_60.bin"
    Option         "IgnoreEDIDChecksum" "DFP-3"
EndSection

Section "Screen"

#    Option         "UseEDID" "False"
#    Option         "UseEDIDDPI" "False"
#    Option         "UseEDIDFreqs" "False"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "IgnoreEDIDChecksum" "True"
    Option         "ExactModeTimingsDVI" "True"
    Option         "ModeValidation" "AllowNon60hzmodesDFPModes, NoEDIDDFPMaxSizeCheck, NoVertRefreshCheck, NoHorizSyncCheck, NoDFPNativeResolutionCheck, NoMaxSizeCheck, NoMaxPClkCheck, AllowNonEdidModes"
# NoEDIDModes
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-3"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    Option         "Coolbits" "26"
    SubSection     "Display"
        Depth       24
    EndSubSection

#    Option "metamodes" "DFP-3: 2560x1440_60 +0 +0"
#    Option "metamodes" "DFP-3: 2560x1440_96 +0 +0"
#    Option "metamodes" "DFP-3: 2560x1440_99 +0 +0"
#    Option "metamodes" "DFP-3: 2560x1440_120 +0 +0"

EndSection

The modelines above are a combination of modelines generated from cvt and some I found on a blog post for overclocking this same monitor. Every single mode results in xorg test screen (cycling RGBW colors). I also specifically set aside the "NoEDIDModes" option because this guaranteed a test screen on xorg start. Attempting to add any modeline inplace other than duplicating default mode gives a xrandr error:

me@host /etc/X11 % xrandr --addmode DVI-D-0 2560x1440_96_2
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  39
  Current serial number in output stream:  40

So I then started x with log level 6 and dug through the resulting Xorg.2. The xorg.conf used here is with the modeline, checks, and appropriate metamode uncommented in the above conf. I'm not going to bother posting the full log because it's 1500 lines of "Mode 320x240d73 is invalid" but here are some parts I think are interesting:


[ 38519.330] (II) NVIDIA(GPU-0): --- Building ModePool for DFP-3 ---
[ 38519.330] (WW) NVIDIA(GPU-0): Unrecognized ModeValidation token "AllowNon60hzmodesDFPModes";
[ 38519.330] (WW) NVIDIA(GPU-0):     ignoring.
[ 38519.330] (WW) NVIDIA(GPU-0): Unrecognized ModeValidation token "NoEDIDDFPMaxSizeCheck";
[ 38519.330] (WW) NVIDIA(GPU-0):     ignoring.
[ 38519.330] (WW) NVIDIA(GPU-0): Unrecognized ModeValidation token
[ 38519.330] (WW) NVIDIA(GPU-0):     "NoDFPNativeResolutionCheck"; ignoring.
[ 38519.353] (II) NVIDIA(0): Using MetaMode string: "nvidia-auto-select +0+0"
[ 38519.353] (II) NVIDIA(0): Requested modes:
[ 38519.353] (II) NVIDIA(0):     "nvidia-auto-select+0+0"
[ 38519.353] (II) NVIDIA(0): Validated MetaModes:
[ 38519.353] (II) NVIDIA(0): MetaMode "nvidia-auto-select+0+0":
[ 38519.353] (II) NVIDIA(0):     Size: 1024 x 768
[ 38519.353] (II) NVIDIA(0):     DFP-3: "nvidia-auto-select"
[ 38519.353] (II) NVIDIA(0):         Size          : 1024 x 768

[ 38519.353] (II) NVIDIA(0):         Offset        : +0 +0
[ 38519.353] (II) NVIDIA(0):         Panning
[ 38519.353] (II) NVIDIA(0):          Domain       : 1024 x 768
[ 38519.353] (II) NVIDIA(0):          Tracking Area: 1024 x 768 +0 +0
[ 38519.353] (II) NVIDIA(0):          Border       : 0,0,0,0

[ 38519.398] (II) NVIDIA(0): Setting mode "nvidia-auto-select+0+0"

That's it... No errors or warnings, but I noticed it selected metamode "nvidia-auto-select" for some reason when I was trying to use this metamode option:

Option "metamodes" "DFP-3: 2560x1440_96 +0 +0"

Next I exported the monitor's edid to .bin file and attempted to override the default timing with the same thing but in file (proof of concept, if I could use a edid file instead of modeline/metamode). Xorg test screen; the following in my xorg.log:


[ 39803.648] (**) NVIDIA(0): Option "IgnoreEDIDChecksum" "True"

[ 39803.759] (WW) NVIDIA(0): The EDID read for display device DVI-D-0 is invalid: [ 39803.759] (WW) NVIDIA(0): - The EDID has a bad checksum. The "IgnoreEDIDChecksum" X configuration option may be used to attempt using mode timings in this EDID in spite of this error. A corrupt EDID may have mode timings beyond the capabilities of your display, and could damage your hardware. Please use with care.

[ 39803.778] (WW) NVIDIA(0): DFP-3 does not have an EDID, or its EDID does not contain a [ 39803.778] (WW) NVIDIA(0): maximum image size; cannot compute DPI from DFP-3's EDID.

At least I got an error this time. Except I am using the IgnoreEDIDChecksum option and I personally checked the EDID's checksum to confirm it is actually correct. I hand crafted a edid.bin with the modeline that I want, but it's unfortunate I can't test it without getting errors like this.

Any help/comments are appreciated :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.