I have a question regarding firewall config on CentOS 7.

What I have done

  1. Disabled firewalld with systemctl stop firewalld.service
  2. Installed and configured system-config-firewall-tui
  3. Tested my configuration, it works.

However, when I reboot it appears as thought Firewalld is back in charge and all I can do to get my ports open is to stop the firewalld service. As I don't know how to use Firewalld can anyone suggest how I can rip out and replace firewalld with system-config-firewall-tui? I am new to using CentOS but am fairly versed with Debian as a Server and Ubuntu Server 14.04 LTS.

UPDATE: I would like to clarify that I don't want to rip out the firewall I simply want to replace firewalld with whatever system-config-firewall-tui uses, which I guess is iptables? Can anyone confirm this?

1 Answer 1


At step 1, try also doing this:

systemctl disable firewalld.service

systemctl stop stops the service immediately, but leaves it configured to start again whenever it would usually do so (i.e. on boot).

systemctl disable removes it from the boot process.

To stop it immediately and prevent it starting on next boot, run both.

systemctl status firewalld.service will tell you whether it's running or how it's configured

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .