2

I am on Centos 6.6 and recently updated my server using yum, it updated a bunch of things and everything seemed fine, but I was also trying to update Ruby RVM and Node.js and NPM (Node Package Manager)... Got a weird error, when I exited as root, then when I logged out and tried to log back in I am now getting this:

Seans-Laptop:~ zweb$ ssh zweb@XX.XX.XX.XX
zweb@50.56.34.89's password:
Last login: Sat Nov 21 05:25:44 2015 from c-XX-XX-XX-XX.hsd1.ca.comcast.net
ERROR: Missing proper 'which' command. Make sure it is installed before using RVM!
Connection to XX.XX.XX.XX closed.

Does anyone have any idea how to fix this? I tried to disable loading the .bash_profile when logging in but that didn't work. I can't SSH into my server at all now from both root and my user account.

All of my websites are still up and running, but I can't login or SFTP to work on them.

  • It might be this bug: github.com/rvm/rvm/issues/2385. Obtained by googling the error. Do you have RVM installed on the server? And do you have physical access to the server? – Faheem Mitha Nov 21 '15 at 19:03
  • Unfortunatly I do not have physical access to the server, it's a VPS on Rackspace... Seems I am completely locked out. – webmaster_sean Nov 21 '15 at 19:52
  • I suggest contacting Rackspace and getting them to help you. – Faheem Mitha Nov 21 '15 at 21:35
  • Ok, I am now able to login through SSH, just needed to do ^C right after entering my password... Now just need to figure out how to fix the 'which' command error. – webmaster_sean Nov 22 '15 at 4:27
1

OK - here's the quick and dirty on how I fixed it.

Basically, after getting into the shell using the ^C trick (after you press enter on your password when ssh-ing in, your immediately press control-C).

Since I'm on Centos, I just did "yum remove which"... then "yum install which".

then I removed and re-installed ruby, nodejs and npm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.