2

I want to tell the FreeBSD kernel to completely ignore a SCSI cam(4) device.

# cat /var/run/dmesg.boot | grep '\<da1\>'
ada0: 600.000MB/s transfers (SATA 3.x, da1 at umass-sim0 bus 0 scbus4 target 0 lun 1
da1: <HP iLO LUN 01 Media 0 2.09> Fixed Direct Access SCSI-0 device 
da1: Serial Number 000002660A01
da1: 40.000MB/s transfers
da1: 1024MB (2097152 512 byte sectors: 64H 32S/T 1024C)
da1: quirks=0x2<NO_6_BYTE>

# camcontrol devlist
<ST1000DM003-1ER162 CC46>          at scbus1 target 0 lun 0 (pass0,ada0)
<ST1000DM003-1ER162 CC46>          at scbus2 target 0 lun 0 (pass1,ada1)
<HP iLO Internal SD-CARD 2.09>     at scbus4 target 0 lun 0 (pass2,da0)
<HP iLO LUN 01 Media 0 2.09>       at scbus4 target 0 lun 1 (pass3,da1)

I don't know what the da1 device is, nor do I want it visible on my system. FreeNAS sees this device and offers it as an option to create a volume on, which is not something I ever want to do.

How can I accomplish this?

Update: It appears this can be accomplished using device hints, setting the keyword "disabled"=1:

hint.driver.unit.keyword="value"

The only problem is, I'm not sure how to specify driver and unit for this device.

0

From the information you have given this looks like an SD card reader that is part of the HP iLO (some sort of administrator interface ?).

To disable it with device hints you have all the information there.

The device driver is da and the unit is 1, which is easy to see under FreeBSD.

hint.da.1.disable="1"

Should do what you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.