0

This is going to seem like an odd request, but it's necessary. I have a wireless router that is not to be used for internet access. The current router that I have is a DLink DIR-626L and I use it to connect to a few embedded devices for an application that I am working on.

For internet, I am hardwired by ethernet into the network. The problem that I am having is that if I connect to my DLink WiFi router, internet traffic wants to go through the DLink router instead over the ethernet port and the DLink router has no internet connection. I know this is going on because if I try to pull up a webpage I get a D-Link error page saying that I am not connected to the internet.

Looking at some other questions, it seems like my router might be advertising itself as a "gateway" and I can't seem to find a way to turn that off by digging through the settings.

Is there a way to tell Linux that all internet traffic should go over the ethernet port?

A few specifications:

-All of the devices that are broadcasting to the router are doing so over UDP. They are just spitting out data to a static IP over a dedicated port.

-I am using Linux Mint 17.2.

-I had this setup working with a small battery powered TP-Link router (TL-MR3040). I didn't do anything special for this, it just "worked."

0

What you can do is configure your dhcp client to ignore the router attribute that comes in the DHCP reply.

Edit your /etc/dhcp/dhclient.conf that defines which atributes you receive via dhcp, and take out from the line that starts with request the word routers.

request subnet-mask, broadcast-address, time-offset; # routers;

After editing, do

sudo service networking restart
  • Thanks for your reply. Here's what I tried and I'm having the same issue: request subnet-mask, broadcast-address, time-offset, #routers, domain-name, domain-name-servers, domain-search, host-name, dhcp6.name-servers, dhcp6.domain-search, netbios-name-servers, netbios-scope, interface-mtu, rfc3442-classless-static-routes, ntp-servers, dhcp6.fqdn, dhcp6.sntp-servers; where routers is the end of a line. I should note that my wired internet goes through a different router. I basically want to turn off internet access over WiFi. – tomsrobots Nov 20 '15 at 18:20
  • "sudo service networking restart" please – Rui F Ribeiro Nov 20 '15 at 18:23
  • I rebooted the computer. I couldn't run "sudo service networking restart" beacuse it was saying "Job failed while stopping." However, I did use "sudo service network-manager restart" which would go through. In either respect, I did reboot the computer to load the new config file. Is there a way to turn off the router as a gateway? – tomsrobots Nov 20 '15 at 18:46
  • yes, deleting the route... – Rui F Ribeiro Nov 20 '15 at 18:47
  • I had to comment out everything past "routers" and not just routers. It appears to be working now. Thank you. – tomsrobots Nov 20 '15 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.