0

I was having this problem (trust issues with apple device and linux):

https://unix.stackexchange.com/questions/241604/trust-this-computer-iphone-4-and-linux-mint-17-2-with-libimobiledevice-1-1-6

I decided to "completely remove" all of those packages listed ie:

libimobiledevice-utils: 1.1.6+git20140213~ppa10
libimobiledevice4: 1.1.6+git20140213~ppa10
libplist1: 1.12~ppa4
ideviceinstaller: 1.0.1-0.2

My intention was to re-install them, hoping it would fix the issue.

I restarted the machine and now I can't login - after I enter my password at the login screen, it just quickly displays a black screen with:

Linux Mint 17.2 Rafaela pc-name tty1  
pc-name login:    

And then goes back to the login screen.

I'm wondering if cinnamon was perhaps uninstalled as a related package?

Can anyone tell me how I can somehow login and reinstall those packages?

System Info

Operating System: Linux Mint 17.2 Cinnamon 64-bit

Cinnamon Version: 2.6.13

Linux Kernel: 3.16.0-29-generic

  • 1
    tried reinstalling said packages from a terminal and rebooting? – schaiba Nov 20 '15 at 8:01
  • could u perhaps direct me to how to undo the "complete removals" I did in synaptic package manager, via the terminal? I haven't found directions yet on Google (from my phone). – user1063287 Nov 20 '15 at 8:23
  • /var/log/apt/history.log might be what you're after. – schaiba Nov 20 '15 at 8:50
1

Solution

This worked for me.

01) Hit ctrl + alt + f1 on startup (make sure Function Lock is on).
02) Login at tty1.
03) Connect to wifi with:

nmcli c up uuid

For more details on this last step see:

https://unix.stackexchange.com/a/158747/92486

04) Re-install these packages:

sudo apt-get install libimobiledevice4
sudo apt-get install libimobiledevice-utils  
sudo apt-get install libplist1
sudo apt-get install ideviceinstaller

// and i had to install cinnamon again

sudo apt-get install cinnamon 

05) Reboot

sudo reboot

Further Information:

Mark For Complete Removal on libimobiledevice4 causes:

enter image description here

Mark For Complete Removal on libplist1 causes:

enter image description here

0
  1. Hit Ctrl+Alt+F1 on startup (make sure Function Lock is on).
  2. Login at tty1.
  3. sudo apt-get install cinnamon
    
  4. Ctrl+Alt+F7

Now try logging in.

protected by Community Feb 4 '17 at 13:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.