I am trying to set up a proxy and every time I try to use it it denies me or times out. I tried every thing. Tor is up and running properly. My system is fully updated and I'm on Kali Linux. Sometimes it won't even go through.

root@kali:~# proxychains iceweasel
ProxyChains-3.1 (http://proxychains.sf.net)

(process:9547): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
|DNS-request| www.kali.org 
|DNS-request| tools.kali.org 
|DNS-request| www.offensive-security.com 
|DNS-response|: www.offensive-security.com does not exist

here is my proxy config:

# proxychains.conf  VER 3.1
#        HTTP, SOCKS4, SOCKS5 tunneling proxifier with DNS.

# The option below identifies how the ProxyList is treated.
# only one option should be uncommented at time,
# otherwise the last appearing option will be accepted
# Dynamic - Each connection will be done via chained proxies
# all proxies chained in the order as they appear in the list
# at least one proxy must be online to play in chain
# (dead proxies are skipped)
# otherwise EINTR is returned to the app
# Strict - Each connection will be done via chained proxies
# all proxies chained in the order as they appear in the list
# all proxies must be online to play in chain
# otherwise EINTR is returned to the app
# Random - Each connection will be done via random proxy
# (or proxy chain, see  chain_len) from the list.
# this option is good to test your IDS :)

# Make sense only if random_chain
#chain_len = 2

# Quiet mode (no output from library)

# Proxy DNS requests - no leak for DNS data

# Some timeouts in milliseconds
tcp_read_time_out 15000
tcp_connect_time_out 8000

# ProxyList format
#       type  host  port [user pass]
#       (values separated by 'tab' or 'blank')
#        Examples:
#                socks5    1080    lamer    secret
#        http    8080    justu    hidden
#         socks4    1080
#            http    8080    
#       proxy types: http, socks4, socks5
#        ( auth types supported: "basic"-http  "user/pass"-socks )
# add proxy here ...
# meanwile
# defaults set to "tor"
socks4 9050

If you notice the readout it is connecting to the default port and to the default DNS /var/lib/proxychains3/proxyresolv hosts. Problems not be due to multiple uncommented chains.

You could edit the above file with DNS pointing to (Google) or (OpenDNS).

Note: Default is TOR So if you're using proxychains without having added additional proxies, you should be using TOR.

Remember to have all browser instances closed before typing proxychains firefox/chrome/safari/etc


Iceweasel has its own proxy settings, which you should be able to configure to use Tor. If not, just use the Tor browser. I've used the one for Windows and OS X. Surely there is one for Linux.

proxychains is mainly for applications that you wish to proxify which don't have native proxy settings, or I guess I should say, which don't have adequate proxy settings.

It may also be that your Iceweasel proxy settings are conflicting with proxychains. Try to disable all proxy settings, or use system proxy settings in Iceweasel, and then try to run it through proxychains.

Otherwise, try to configure Tor from within Iceweasel, or use try with a different browser.

Try proxychains curl -skLvi 'https://www.google.com'

That should give you some verbose output as to what may be going on. If it returns a valid response, you know proxychains is working and you need to start looking at your browser settings. If not, then it's probably an issue with DNS itself or something going on with the Tor relay.

Also, if this is a laptop that you use on multiple networks with other proxies, echo $http_proxy; echo $https_proxy to make sure those variables aren't set. If so, they will interfere with proxychains, which will try to send through those proxies first, which means if you're not on the network where those proxies are located, then DNS will fail, as will everything else.

As a last resort, as long as you aren't up to anything illegal, try turning off DNS leak protection in proxychains.conf, and see if that helps. It has been known to sometimes cause issues in certain situations.

You can also try using a dynamic chain instead of a strict chain in proxychains.conf. This may be where your problem lies. In a dynamic chain, the dead proxies get skipped. You may be running into a dead proxy, which could be causing the issues you are seeing, since all proxies in the chain have to be alive and go in order with a strict chain.

  • it still gives me timeout errors – Bhagyesh Nov 20 '15 at 4:43
  • When you try to curl google.com via proxychains you get timeout errors? Have you tried everything I have suggested, such as disabling DNS leak protection? – rubynorails Nov 20 '15 at 5:15
  • See my updated answer regarding dynamic vs strict chains. I believe this may be what's causing your issue. – rubynorails Nov 20 '15 at 5:19

You should:

  • add a # before strict_chains
  • remove the # before dynamic_chains
  • add (socks5 9050) without () just under socks4 9050)

and save your conf file for these changes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.