1

I have been trying to install Canon laser printer LBP2900B in Linux Mint 17.2 Cinnamon 32bit.

Whenever I give a print order monitor will say " printing" ! After 2 seconds it will say," printing cancelled " !

When i check the printer status( captstatusui -P LBP2900),the message i am getting is:

Communication error:
    - is the printer turned on ?
    - is the cable correctly connected ?

I reconnected the cable,still the same error message !I am not getting " Ready to print " message after running the command captstatusui -P LBP2900

[Click to see screen shot

And in the terminal it says: "(captstatusui:8733): GLib-CRITICAL **: Source ID 10 was not found when attempting to remove it "

I tried many versions of CAPT driver from canon site including latest 2.7 ! The main link i referred is:

http://www.e-lokam.com/internetsoftware/cannon-lbp-2900b-printer-installation-in-mint-16/

Another link itried :

https://radu.cotescu.com/how-to-install-canon-lbp-printers-in-ubuntu/

0

First you turn on the cpu or laptop and give time to 10 or 15 min to turn the printer after go to terminal and check the printer status in terminal by using this command: captstatusui -P LBP2900, it shows what is printer's current status, printer is not yet ready or some error is coming mean restart the CPU or laptop and check the status, still printer get ready to print.

Use this file to install the via synaptic driver portserve, gsfonts, gsfonts-other, gsfonts-x11

0

I had a the same printer and there isn't driver for this model, I lost months in search of it. And even if there were there would be other problems, I am sorry

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.