2

I can't get net.ipv6.conf.eth0.autoconf to = 1.

Goes back to 0 after every reboot causing eth0 to never auto-acquire a global IPv6 address. I am running a headless Debian Jessie (kernel 3.16.0-4-amd64).

After correctly assigning an ULA address to my eth0 like this:

/etc/network/interfaces:

allow-hotplug eth0
iface eth0 inet static
address 192.168.1.100
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 192.168.1.1

auto eth0
iface eth0 inet6 static
address fd69:6666::
netmask 64

What i've tried so far

  • adding net.ipv6.conf.eth0.autoconf=1 to /etc/sysctl.conf;
  • setting net.ipv6.conf.all.autoconf=1 and net.ipv6.conf.default.autoconf=1 in /etc/sysctl.conf before eth0 autoconf. They correctly stay 1 after rebooting;
  • making sure it's not set anywhere else (grep -iR 'autoconf' /etc).
  • appending pre-up sysctl -w net.ipv6.conf.eth0.autoconf=1 to the inet6 static stanza of my /etc/network/interfaces;
3

Try adding

autoconf 1

to your inet6 static stanza. See man interfaces.

  • Well that was easy! – ppparadox Nov 20 '15 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.